XBee Frozen - USB XBee Dongle


I have a XBee on a SparkFun USB XBee dongle. I already tried several things to ‘unlock’ my XBee: when popping-up Info message short circuiting the GND and RST pins, etc. The last thing I tried was:

  • Take the module out of the interface board.
  • Connect the interface board to the computer.
  • Open X-CTU make sure Baud Rate is set to 9600.
  • Go to “Modem Configuration”
  • Put a check in the “Always update firmware” box.
  • Select proper modem from drop down menu.
  • Select proper function set and firmware version from drop down menus.
  • Click on the “Write” button. After a few seconds of trying to read the modem, you will get an Info box that says Action Needed. At this point, CAREFULLY insert the module into the interface board.
    You may get the info box again a short while after, just use unplug the interface board and plug it back in again.

This works: I get the following message:
Getting modem type…Programming modem…OK
No AT parameters to set
Detected baud rate difference.
Make sure PC and modem baud rate is set correctly
Write Parameters…Complete

But when trying to change a value of the modem e.g. baud rate I get
Getting modem type…Programming modem…OK
Failed to enter command mode
Found bootloader active reprogramming firmware.
Write Parameters…Failed

I even can’t connect to the modem or read modem properties.

What else can I do to “restore” my XBee.


Try optimizing the USB drivers as described at http://www.digi.com/support/kbase/kbaseresultdetl?id=3418.