XBEE only transmits when using a USB Explorer


I have a strange problem. I have a number of XBee S1 devices (standard and pro) and a number of explorer and breakout boards for easier connection. My setup was working fine until about a week when I wanted to switch out a standard S1 with a Pro. After connecting to XCTU, my devices will now only transmit when connected to regulated explorer breakout boards (eg. Sparkfun USB Explorer or Regulated breakout board). I thought this may have been an issue with power, but I have a power supply and can confirm that the XBees are being powered properly. Even if I attach 3.3v directly to the XBee pins, nothing is transmitted. But, if I run the power through a regulated breakout board, all is fine. Does anyone know what would cause this issue? Why would it have worked before, and not now? I am on the latest firmware, and have tested with various XBees, power supplies, and breakout boards. All exhibit the same behaviour.

I am officially out of hypotheses. Any help is greatly appreciated!

which xbee module are you working with and what firmware version?

I am working with S1 (802.15.4) all running on 10ef firmware version

Most Arduino code uses API mode and API mode for the Zigbee and Digi Mesh interface. Not transparent mode or the 16 bit addressing function on the XBee 802.15.4 modules.

Could also be that your power supply is not able to provide the radios with the desired 400mA of current causing the module to go into a starvation mode or simply are not being powered up.

Definitely not a power issue. I have a dedicated power supply that I have tested it on. I have set it to allow up to 1A, which the XBee never comes close to hitting.

I am not using an Arduino. I am interfacing with a Raspberry Pi which receives the raw data packets to the Serial Port.

Have you verified that you are sending the data on the proper Pins? IE the radios Data In line?

Ya, the pins have been verified and the sensor data is correct when transmitting. This is actually in regards to the same issue as mentioned in another question I have on the forum:


For whatever reason, everything works fine when IR is <5000ms. I just can’t understand what would cause this. Does the IR somehow impact the power consumption and connectivity for transmission? For example, does a faster IR keep more current flowing which helps the transmission? This still wouldn’t explain why it works with USB Explorer at any IR, unless the USB Explorer is using a different pin configuration or circuitry when the XBee is connected? E.g. capacitors, pull-up/pull-down resistors, etc.

Sounds like you are having issues with power. Try decreasing the PL command on the XBee.

What is your wake time? is it Greater than 500mS?

It is set to never sleep - would the wake time still be relevant?

If neither device is sleeping or a Coordinator, then it should not be taken into account.