Xbee Pro 60mW will not communicate with X-CTU or Reset

I have an Xbee Pro 60mW that is connected to the computer using a Sparkfun USB XBee Explorer. I have checked another Xbee and can read it, but when I connect this one it tells me that it is unable to communicate with the modem. I have tried all Baud rates and know what it was left at 2 days ago with no luck. When I try to restore the firmware it asks me to reset the board. I have had no luck resetting the board by connecting Reset to Ground. Any help would be greatly appreciated.

perhaps you should try ruling out the possibilities of a firmware failure or a hardware failure by trying it on a Dev Digi Board or a serial board with serial com in first. Let us the know the result then, that’s what I think…

Also, check ur X-CTU version. Latest version is at

I have tested with the most current X-CTU with the same results. I do not have a Digi Dev Board or a serial board to test with. I ruled out the possibility that the Sparkfun Xbee Explorer I am using is bad after testing with other Xbees.

Has it been flashed before? Or it came faulty like that when it arrives?

I’ve done some silly things in the past, but mitigated by ticking the boxes of “No Baud Change” & “Enable API” (cz I may hv forgotten wtr it’s API enabled or not).

Is the radio working? Hv u checked? (Send a frame packet and loop it back to ur source)

It has been flashed before and I know what the settings were because it was working and running a robot on Sunday afternoon. It then wasn’t touched until today and refused to communicate with anything (the arduino it had been talking to or the xbee explorer). I also tried enable API, but it still won’t let me update it and asks to be reset which it won’t let me do either. It has had to be reset a couple of times starting from the time it came so I think it has had issues from day 1 particularly since it is less than 7 days old.

almost all devices from Digi has a 5 year warranty period (please correct me if I’m wrong Digizens). Perhaps u can make use of that warranty now if it’s still the same result.
I’ll try to post any idea I can think of if it ever occurs to me. :slight_smile:

Thank you! I will try that.

Do you need connect VCC,GND,DIN,DOUT,RTS & DTR. not only GND,DIN & DOUT, see your manual… in Design notes. after pin signals

I have a breakout board with an FTDI chip that connects an Xbee to usb and that I know is working as it has been tested with other Xbees and works fine.