XBee PRO S2C responds to active endpoint request?

I have a few XBP24CZ7WIT-004 modules with ZIGBEE TH PRO feature set, fw version 4059.

The aim is to create a Zigbee HA compliant endpoint with it, the coordinator is an Orvibo mini hub that is supposedly Zigbee HA compliant. AO is set to 0x0B, but I tried with 0x07, the results are the same.

The module successfully joins the PAN. Shorty after that the coordinator sends an active endpoint request that is NOT sent to UART (I’m pretty sure that the requests are sent, because previously I used XB24-Z7WIT-004 modules, and the active EP requests were received every time through UART).

The fun part is that the coordinator says (without me responding to its request) that I have 1 endpoint, which is a level control device - exactly what I implemented in my test bed. So it seems the XBee module once learnt that I have a level control endpoint, and responds to the coordinator on my behalf… which is acceptable for me, but:

  • I changed my endpoints. How can I convince the module to reset its endpoint table (without completely reset the module and set up everything again)?

  • When I receive e.g. a Move to Level command, it is sent to endpoint 0xEE, even though my endpoint address is 0x01. AFAIK 0xEE is a Digi reserved endpoint, but I found nothing about it.


You need to set the AO and AP to see the ZDO pass thru commands.

AP = 0x02. Tried with AO = 0x07 and 0x0B, but no active endpoint request was received.

Did you try AO3 - Explicit + unsupported ZDO ?

Not yet, because I will need to receive binding requests, so I will need 0x0B anyways… but you’re right, I should’ve tried it…

[a few ninutes later…]

OK, I tried it, and it works…

I have an other question then: will I receive binding related ZDO messages with AO=3? :slight_smile:

I don’t know.