XBee-PRO ZB SMT Function: 4016 - Not Found in XCTU

The model of the XBee-PRO ZB SMT that produces “Function: 4016 - Not Found in XCTU” message in XCTU is XBP24CZ7UISB003. When I add radio device using XCTU, the above message is shown, and when the Radio Module is clicked, a dialog box popped up that says could not find firmware for the device. I clicked on Yes to update the radio firmware, and provided the file 82003342_B.zip that I have downloaded from digi website, another dialog box that showed Installed radio firmware but it was empty. I proceeded to perform XBee recovery, and provided XBP24C for Product family, ZigBee for Function set, and 4043 for Firmware version, then Action required dialog box popped up and another dialog box popped up that said no active bootloader in the module. However, when I used CoolTerm to connect to the module, the following was displayed:

B-Bypass Mode
F-Update App
V-BL Version
A-App Version

I tried to update the firmware xbp24c-zb_4043.ebl by selecting option F, and it seemed to upload the firmware but failed to work.

Your help is appreciated.

What do you use to connect your Xbee to your computer ? If you’re using an Arduino, be sure you are in USB mode and that the RESET input of the Arduino is connecter to the GND.

The Xbee module SMT module is connected to a FTDI module.

When I did a XBee recovery, the following message was shown:

  • Looking for active bootloader… [ERROR]
    There is not an active bootloader in the module.
  • Resetting and entering bootloader… [ERROR]
    There is not an active bootloader in the module.

The bootloader works on CoolTerm, and I am able to set the module to bypass mode then talk to it in transparent mode.

What you have is a Programmable radio. When you do your Discovery in XCTU, you need to tell it that you are using a programmable radio. You also need to choose the Bypass mode if you want to upload an XBee Firmware file to the radio. Choosing the Update option only tells the 2nd processor that you want to upload an application onto it and not on the RF processor.

I set the module to Bypass mode, then use XCTU to communicate with the module. I was able to communicate with the module in transparent as well as API mode, but still no luck in uploading the firmware.

When you use the Discover function in XCTU, Enable the “The radio module is programmable”. You will find that then you can read, write and change firmware versions on a programmable module.

The following is returned when I issued ATVL on the Zigbee module:

Xbee-PRO S2C BETA ver: 4016
Build: Aug 19 2010 19:42:59
EZNet stack ver: 4253
HW Ver: 21423030
Bootloader ver: 4253

Anybody out there has any idea about this version that returns the “4016 - Not found in XCTU” message, and not able to get into the configuration working mode in XCTU?

I solved with old version XCTU ver.

  1. Setting the module to Bypass mode.
  2. Check Enable API in PC Setting Menu
  3. Select Firmware version in Modem Configuration Menu
  4. Check Always Update Firmware
  5. Click Write

If errors, Uncheck Enable API in PC Setting Menu and re-try.