Xbee Series 2 module not being detected

Hey everyone,
I have a digi Xbee Series 2 module attached to my bl4s150 board. The board is working perfectly as all dynamic c programs are running. However, when i start my connectport X4 i am not able to detect the module. It is powered correctly as 2 LEDs are glowing and the USB-serial cable is also attached.
Please help


Have you checked that Xbee series 2 module and ConnectPort X4 are working on same channel and both are having same PanID?

Also make sure the firmware types are compatible - if the BL board also has coordinator firmware, the everything is forming their own MESH. The bl4s150 needs to have either router or end-device fw.

How do I check the PanID of the module and whether they are working on the same channel ?
Also how do i ensure that the bl4s150 has a router fw ?


You can check the PAN ID and channel for Series 2 module through X-CTU software.

Through the XCTU software, when i test/query it says unable to communicate with modem.

Thanks…the Zigbee is working now.
It was the router fw problem

>> when i test/query it says unable to communicate with modem

Yah, that is an unfortunate issue of timing - XCTU incorrectly sending those “+++” trying to break into an AT fw sometimes causes the API-enabled FW to show up as no response.

If you do know that all units are 9600 baud and have API-frames enabled, then setting that in XCTU speeds up the test/query/read greatly.

I am having a similar trouble with by xbee S2.
Experienced members Kindly visit this thread and help me out.

Can Xbee2 module be recoevered w/o using a development board
(http://forums.digi.com/support/forum/viewthread_thread,9228 )


You don’t require a Digi XBIB dev board, but unless your time is priceless (meaning you work for free) then you’ve probably already lost more money than you saved by not buying one.

Any Xbee carrier board from SparkFun or Arduino suppliers which support TX/RX, RTS & DTR to the XBee should be able to reflash and manage the XBee. Having access to a reset button also helps.