XBee stop to comunicate after baud rate change

I hope someone can help me.

I’m using two XBee Series 2 with this configuration:

  1. ZNET 2.5 COORDINATOR API (1147)

The first XBee is connected to an Arduino board and I’m able to switch a remote pin.

All works perfectly with the default baud rate of 9600, but now I need to change the baud rate to 4800, because I have to send also some GPS serial data.

I have changed the baud rate to 4800 in both XBee with X-CTU, and I edited my arduino code setting:


XBee xbee = XBee();

void setup()

Unfortunately now the the XBee can’t comunicate each other, the assoc led blink and the RSSI led remain off, and the remote pin don’t switch.

What I have to do to make them work with baud rate of 4800?

1 Like

Try upgrading the firmware on your radios to the supported ZB function sets and firmware versions. The Znet 2.5 code is now 3 to 4 years old and no longer supported by anyone.

1 Like