Xbee Stops Searching For Coordinator?

Hi all.
I’m trying to assamble a healty communication between two Xbee modules. I’ve succedd what I want but there’s a problem that I couldn’t figure out.

There are 2 parameters in X-CTU which makes me confused.

JV - Channel Verification

NW - Network Watchdog Timeout

I’ve read all instructions from datasheet, I’ve googled many times but I couldn’t find any significant solution.

What is my problem?
I’m working on some “worst cases”. For now, the worst case for me is starting of router before long time (like 10 mins.) from starting of coordinator. I’ve solved this problem by setting JV = 0 and NW = 1. But if I set JV = 1, NW = 1, and if I started coordinator long time (like 10 mins.) after router, router does not trying to find coordinator. Why is this happening? I couldn’t understand what’s going on in Xbee.

hi doumo!,

It seems to be a bug.
It is reported here.

It seems that the too same problem occurs although tried also on version 2x8c.

Thanks for answer chobichan but I couldn’t get which article are you talking about. Crosstalk problem?


It is this portion.

  •                   Version 2xA0 Release Notes                       *

Release Date: July 13, 2011
ZigBee Stack: EmberZNet 3.5.1 ZigBee-PRO stack


  • Network Watchdog option (ATNW), modules won’t properly join to the coordinator after leaving the network
    after a watchdog timeout occurs.

I saw this portion, but I don’t understand how did you associated my problem with this bug? My problem is about JV (Channel Verification) parameter. If I set this parameter 1, my problem occures, but if I set this parameter’s value to 0, my problem disappears. And I want to learn what’s going on in Xbee module? Why does Xbee stop searching if I start coordinator after a while router?



  • Network Watchdog option (ATNW), modules won’t properly join to the coordinator after leaving the network
    after a watchdog timeout occurs.

first, since the NW command is a command applied only to a router, this paragraph is attached to the router – it is .

When this problem sets to JV=1 and NW is except zero, I can consider on the occurring problem.
It seems that however, it is not writing to release notes not much in detail.

If it cannot be convinced for my saying, how is it that contacts on the support team of Digi?

This still sounds like a bug!

JV=1 means the router aggresively should seek (‘demand to find’) a valid coordinator after a reboot. JV=0 means as long as the router finds other traffic, it assumes the coordinator will show up eventually.

I too have struggled with this problem, under firmwares 2x86, 2x8C, 2xA0 and even an unreleased 2xA6.

Yet even with WH={some value}, routers (especially S2C) do NOT rejoin the coordinator if the coordinator has been offline for too long. One requires to powercycle the errant routers to get them to rejoin. Since my S2C ‘routers’ are hardwired into my HVAC system, this means I need to reboot my furnace at the fuse-box!

The Digi support folks say that I am mistaken and they cannot recreate my problem.

Yet I have NOT tried turning JV back to 0. One should not have too as the JV=1 function is useful, but it is worth a try. I certainly need my routers to rejoin the coordinator even if the gateway is offline for days (or weeks).

thank you “lynnl” and “chobichan”. I realised that I do not have enough English reading level to understand all of your words :)) (English is not my mother tongue :slight_smile: ) But in summary I understood from all your replies that my problem is not about my configurations, it’s looks like a bug. (I hope I understood that correct). And it’s look like there’s no solution except contacting Digi support team (or waiting for firmware upgrade)

If you think I understood your replies incorrect, I’m asking you to tell me the problem by using little more clear English :slight_smile: Sorry for my terrible language.

Again, thanks and thanks and thanks and… :slight_smile: