XBP24BZ7 (S2B) fail to communicate when using Destination Address but works when broadcasting


I have two XBP24BZ7 (S2B) Xbee pro modules. They work perfectly in AT mode and even in API mode when the Destination Address is broadcast (0x000000000000FFFF).
The problem arises when I try to set up the destionation address to be the serial number of one of them. the receiving xbee doesn´t receive any data.

To do the testing I am using the following set up.

Software: X-CTU in terminal mode
Packet generator (http://ftp1.digi.com/support/utilities/digi_apiframes2.htm) Set up in 0x10 (transmit request), API2, Zigbee.

1 Xbee set up as ZIGBEE Coordinator API:
PANID: 1234
SH: 7D33A2
SL: 40A04C83
AP: 2

1 Xbee set up as ZIGBEE Router API:
PANID: 1234
SH: 7D33A2
SL: 40A04C8E
AP: 2

I have generated the packet:
“7E 00 12 10 01 00 7D 5d 33 A2 40 A0 4C 8E FF FE 00 00 66 67 68 69 47”
With payload: 0x66, 0x67, 0x68, 0x69
and 64DestAddr: 7d33a240a04c8e
and 16DestAddr: 0xFFFE

and I have try to sent it from the coordinator using the “assemble packet” but nothing shows up in the router terminal. The distance between the xbee modules is about 1 meter.

I have tried another test, sending a packet from the router with the SH:SL address of the coordinator but again nothing shows up in the coordinator terminal.
I don´t know what is going on. I have updated the firmare and check the configuration of each xbee module over and over again but I don´t see nothing wrong.

I appreciate any help.
Thanks in advance

Where are you getting that 64 bit address from? Who is it you are trying to send the data to?


I am getting the 64 bit address from the Serial Number of the Router using X CTU.

I am trying to send the data from the coordinator to the router and also from the router to the coordintator.

Try using transparent mode and unicast mode and make sure that works before you go on to API mode. Then change one to API mode and only use API mode 1 (non escaped characters). Then see what happens.

Finally the issues were solved.

To send data from the router to the coordinator the 64 bit address has to be 0x0 and not the SN.
The reason of why the data didn´t arraived from the router was that the network address changes every time is turned on.

I don´t know why the network address cannot be set to a specific number such as the PAN. To solve the issue the coordinator has to discover the nodes in the network and find out the network address.