XCTU in Linux: fails from user level, runs OK as root

I installed XCTU in Ubuntu Linux at /opt/XCTU-NG.

If I run the program as root by clicking on app, all is well and everything functions as expected.
XCTU opens normally and all functions are OK.

At user level, using the desktop file created by the installer:
XCTU fails with reference to an error log.
The log file contains:

!ENTRY org.eclipse.osgi 4 0 2016-06-30 14:35:22.410
!MESSAGE An error occurred while automatically activating bundle org.eclipse.core.resources (47).

Has anyone seen this before?
Can anyone suggest a way to troubleshoot this?

Thank you for your attention.

when I run XCTU from root (and all seems to work as it should):

Invoking MENU: XCTU > Add Radio Module
MENU: XCTU > Discover Radio Module
invoking Add or Discover at the Xbee+ and Xbee(magnifying glass)

…work only on the first xbee unit, which becomes the coordinator.
Both menu choices (Add and Discover) can only locate the first unit.

To scan for other/additional Xbee units can only be done from the first Xbee’s box+icon on the left side of the XCTU window: Clicking there on the icon for mesh network will scan for and find the additional Xbee radios in range.

Is this normal?
Just trying to benchmark it for my notes…

Provide read/write permission to user for the directory in which XTCU resides, and for all files contained therein.

1 Like

I can’t able to execute XCTU application through command line prompt in ubuntu.It is showing error and created one log file which details is given below—

"!ENTRY org.eclipse.osgi 4 0 2017-01-13 09:58:44.134
!MESSAGE An error occurred while automatically activating bundle org.eclipse.core.resources (47).
org.osgi.framework.BundleException: Exception in org.eclipse.core.resources.ResourcesPlugin.start() of bundle org.eclipse.core.resources.
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:300)


Anyone please resolve this problem.Thanks in advance


I am not able to directly contribute understanding of the problem you have posted.

When I posted this original question I was not knowledgeable with the Linux operating system.
My understanding has improved somewhat.

My problem with XCTU was lack of understanding the intended installation process.

I will post the solution I discovered to my installation of XCTU. I hope this may possibly be helpful for you:

Ubuntu ver 14.04

  1. Download the XCTU tar file from Digi.

  2. Unzip the tar file. The content is a single file, 40002881_C.run
    This executable is the installer.

  3. Change the file properties to make the installer executable

  4. As root, execute the installer.

  5. The installer will ask for an installation directory.
    The suggested default location is /opt/Digi.

  6. When the installer completes the installation, look for a file XCTU.desktop
    This is the desktop file created automatically by the installer.
    Move this file to /user/share/applications. (in Ubuntu)

Notice, this application will run (at user level) only when called from this desktop file.
The EXEC instruction calls the XCTU program with required command-line parameters determined upon installation.

There is a suitable icon for desktop included in the installed files, which is referenced with the desktop file.

  1. Change the file permissions of both the installation directory and all it’s files to user, read/write.

  2. Ensure the XCTU program has access to any serial ports used (the user has entry in the “dialout”).
    Reminder: after adding user to the dialout, you must log out and back in.

On another install using this procedure, the XCTU program failed to start, posting an error message directing to a log file. The path described for the log file is /home/rick/

The log file cited a folder for work files /opt/digi/xctu-ng/workspace.

This folder was not created in the installation process.
The solution was to create the workspace folder manually, set it’s permissions to READ-WRITE.

1 Like

Yes that is normal. The Add radio button only looks on the local COM ports for any radios powered up and connected to the PC. For Remote modules, you must use the discover function under the local radio.