XCTU Linux error on Ubuntu 20.04.2


There are several unanswered questions on XCTU for Linux. Linux is used by a critical group of developers and these basic installation questions need answers.

I’ve tried installing and running both:

  • XCTU v. 6.5.5 Linux x64
  • XCTU v. 6.5.5 Linux x86

Both install just fine and the installer exits properly, but when the XCTU application begins there is an error message about ​"no swt-pi-gtk in java.library.path".

This is the error even when setting the environment variables in the desktop icon file.

Getting XCTU working on Debian or Ubuntu 16, 18, and the 20.04 LTS releases seems a reasonable and useful goal for the XCTU Linux developers.

The manufacturer’s own test software should work. It doesn’t.

Who has worked through these issues? What is the solution for Linux generally and Ubuntu in particular?


!SESSION 2021-03-17 12:43:55.484 -----------------------------------------------
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Framework arguments: -clearPersistedState
Command-line arguments: -os linux -ws gtk -arch x86 -clearPersistedState

!ENTRY org.eclipse.osgi 4 0 2021-03-17 12:43:56.876
!MESSAGE Application error
java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
/opt/Digi/XCTU-NG/configuration/org.eclipse.osgi/155/0/.cp/libswt-pi-gtk-4629.so: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
no swt-pi-gtk in java.library.path
Can’t load library: /root/.swt/lib/linux/x86/libswt-pi-gtk-4629.so
Can’t load library: /root/.swt/lib/linux/x86/libswt-pi-gtk.so
/root/.swt/lib/linux/x86/libswt-pi-gtk-4629.so: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

Do you have the most recent version of Java installed on your system?

I have Ubuntu 20.04.2 and can install or verify whatever.

I have no idea what Java I have.

But it doesn’t work.

If Java is necessary, then that should be part of the installer to auto-detect or locate or at least part of the instructions.

Also, installing various versions of Java can be quite a challenging task in itself.

You you also do an ln - s to /opt/Digi/XCTU-NG/configuration/org.eclipse.osgi/155/0/.cp/libswt-pi-gtk-4629.so: libgtk-x11-2.0.so.0

That has resolved other customers issues with Eclipse and Ubutu. Also make sure you have a current version of the Java JDK installed.