XTEND 900 joins packets and send them back-to-back

I am trying to establish two-way connection between two XTENDs. The serial and RF baud rate is 115200. Loosing a single packet is not crucial.
The first modem sends a 46 byte packet every 45ms, the second modem sends a 24 byte packet 2ms after it receives the packet from the first modem.
Currently I have both modules programmed to 206E firmware.
RR = 0, MT = 0, RN = 0, TT = 0,
PK = 50 on the first module, PK = 30 on the second module
The problem I encounter is that the module waits till it receives two packets and then sends them back-to-back. Thus the gap between the received packets is longer than 45ms (around 60-70ms), which subsequently disturbs the timing of the response of the second module. I need the modules do sends the packets out one by one with the controlled gap not back-to-back.
I was able to make it work for the first modem with 2067 firmware, but the second module (2067) still joined the packets it was transmitting. PK did not really matter with that firmware, I left it at 800 on the both modules. Now when I roll back to 2067 from 206E, the behavior does not change.
I probe the signals on the RX/TXc LED pins of the modules.
Did I miss any configuration or anything else?

Set RO to 0.Then the PK value will work.

Sorry, mvut. I did not mention RO. It was set to 0 from the beginning.
I finally got it working at even faster speed than I was planning in the beginning (around 30ms).
I had PK at 46 and 24 respectively this morning. But both modules were sending two packets back-to-back. Then, I tried lower PK values and it fixed the situation. But what’s interesting is that I was able to increase PK values back to 46 and 24 and did not observe any joining effect.
I encountered such inconsistent reaction to change of configuration bytes before. Like the one with the newer firmware I described above. Any precautions I should take to avoid this in future?

what I would suggest is setting the PK and RB a little lower. Then you will be fine.

1 Like

as long as you mentioned RB value…
Does your XCTU allows to change RB?
My XCTU 6.1.1 does not have RB option at all, which is kind of strange, providing that the manual is all about the setting the right RB value.