Xtend can not connecct with X-CTU any more?

All my Xtend900 module was working property, until I do some programming. I save one profile from one Xtend900 module, and write to another module. During the writing, X-CTU shows a mistake that lost connection, I notoce that the comm port rate in the profile are different. so programming fail. then I try to connect to the xtend, it can not anymore, no matter what baud I set.

when test/query, it shows the connect failed, some action required, so I press reset button 2 second, the info window close, still show the connection failure. try sometime again, it is the same.

Did I lost my xtend, can not be.

Hardware: XT09 with digi PKG-U adaptor

if I follow the recovery procedure, by choose XT90-9XTEND 115K hopping(digimesh) version 8064

it shows error:

Getting modem type…Programming modem…Flash checksum error failed
Found bootloader active reprogramming firmware.
Write Parameters…Failed

I had the same issue when updating firmware on a XBee Pro module through XCTU.
It seems that if you lose connection for some reason while updating firmware/programming, the device is unable to connect again.
I solved it by connecting to a XBee programming board, and using an older version of XCTU to try to connect to the device. After several resets, XCTU was able to communicate to the device and write the firmware.

I would first recommend trying to write the profile again at the baud rate the profile was setting on the radio. If that does not work, then use the restore function using a baud rate of 9600bps. If neither work, follow the steps outlined at http://www.digi.com/support/kbase/kbaseresultdetl?id=3402

I tried something. this xtend is a digimesh module, with default profile. if I just select function set to 9600/115k hooping, and write, then it will be the problem.