Access denied when installing AnyUSB driver on Win2k3/Citrix VM

We have several Windows 2003 R2 servers running on VMWare ESX 3.0.2
One of them runs fine with a Anywhere USB/5 (G1) Box.
Now we have an application, that ness to run in one of the other servers as a Citrix (Presentation Manager 4.5) Application, needing USB Dongle support.
When I try to install USBAnywhere Driver (v2.90 April 6, 2010, tried as local and domain admin), I receive the following error:

Installing system drivers…

InstallRootEnumeratedDriver: last error=5
UpdateDriverForPlugAndPlayDevices FAILURE: access denied

InstallRootEnumeratedDriver FAILURE: access denied

What’s going wrong?

Thanks for your help!


The v2.90 AnywhereUSB driver is older. I suggest using the current release v3.10 AnywhereUSB driver instead.



Does that help?

Hello, jeremy, thanks for responding.

I tried V3.10 (system is 32bit) with the same result.



Does the Start Menu shortcut to the AnywhereUSB Configuration Utility get installed?

Is there anything “particular” about that server that you think might be causing these “access denied” problems? Are you running the installer directly from the system console, or are you remoting into the system through RDP, etc.?


there is no shortcut in the start menu, no AW*.* files in the system32 folder. I start the installer from the virtual console in VMware VI Client.
The only obvious difference between the servers with successful installation and those failing setup is the Citrix/Terminalserver environment.


Do the .zip versions work any better?



Be sure to first extract the .zip file before running the setup executable.

No, tried the

Network Attached USB Hub Installation Version 2.3.2
Searching for previous installation…
No previous version found
Installing system drivers…
InstallRootEnumeratedDriver: last error=5
UpdateDriverForPlugAndPlayDevices FAILURE: Zugriff verweigert
InstallRootEnumeratedDriver FAILURE: Zugriff verweigert
Press Enter key to exit.

Logged in as local admin, moved zip to c:\install, unpacked it and ran setup.exe from windows explorer.

No shortcut in All Programs

At this point, my best guess is that the cause of the issue is somehow particular to that computer and not due to a problem with the AnywhereUSB software itself.


I don’t think so, because I tried on our second Citrix VM with the same result. So I believe there’s some trouble caused by the Citrix installation.

If you have any idea …

Otherwise, thanks for your support.

regards from good old germany


To install the drivers you need to have a admin rights