AnyWhere USB Share Issue

Here is the scenario

I work with a domain which has both thin clients and computers attached to it. Because of security and the ICT policies that are in place, it is not possible for the thin client users to have USB access.

To resolve this we have bought one of the USB anywhere devices so that our users can open pictures/data from a USB device VIA the network.

Our servers are WS2003R2 and the client devices us WinXPSP3.

My plan was to give the Anywhere USB device a DNS record and attatch it to one of our servers. This has worked and the USB drives can be seen locally on the server.

However Because I require normal user access to the files I need to share the folder out to our domain users so that it is visible. When I share the devices I get the following error when trying to view the share:

Not Enough Server Storage Is Available to Process This Command

I have googled this error and followed the Microsoft “fix” which has not worked. When I attatch the USB storeage locally to any domain machine and share the directory I can see the files.

Has any one encountered this issue because I am beginning to run out of ideas.


Hi there,

I just came across another thread where that “not enough server storage” error was mentioned.,7122

Are you by chance related to that other customer/thread, or are you just seeing the same issue?

Thanks for the responce…I am less than impressed with Digi’s answer. I ordered this device with the intention of using it with various UBS devices. I cannot believe that “USB storage devices aren’t really recommended for use with the AnywhereUSB” SHOCKING!

I have no relation to the other call, I think we are both having the same issue though.


My statement was actually more related to trying to use a large USB 2.0 mass storage device with an AnywhereUSB for a scenario like backing up large amounts of data. That particular scenario is known to not work well, therefore I can’t personally recommend it based on feedback.

But for what you (and the other customer in the other thread) are looking to do with the USB storage device, that seems to be working in the basic / locally-attached sense, so that’s good to hear.

It’s also good to hear that you were able to try a test I wanted the other customer to try - about connecting the USB storage device directly to the PC, in order to pinpoint the cause of the failure.

I understand that you were able to try that, and that error doesn’t happen in that scenario, so that seems to point to the particular combination of using the AnywhereUSB with the USB storage device, with file sharing.

We’ll do the best we can to help. I don’t have any suggestions at this point in time though.

The AnywhereUSB is designed to function just like a USB hub but sometimes compatibility issues crop up, and sometimes we haven’t gotten reports of them before so it’s difficult to say what the cause of the issue is.

What is the most simple way to re-create this? Does the host PC have to be a domain controller, or would this issue still happen if, say, a Win XP workstation (logged on locally as admin) was used instead? Would another XP workstation be able to access that file share?

In other words, have you done any troubleshooting to pinpoint what is required on, or about, the host PC, for this issue to happen?

>> “Because of security and the ICT policies that are in place, it is not possible for the thin client users to have USB access.”

Maybe these policies are contributing toward this issue? What exact related policies are in place? I’ll ask the other customer if there are any related policies in their environment.