AnywhereUSB 2 Plus "Invalid Client Cert"

On AnywhereUSB 2 Plus I have configured two Groups Group1 has access to USB1 and Group2 has access to USB2

In client settings via the web interface i have configured clientID1 to get access to group 1 and clientID2 to get access to group2.

So far so good, I am able to connect with clientID2 to group2 however when i try to connect clientID1 to group1 I get a red X and the error message “Invalid Client Cert”

Why is my client cert invalid? Which client cert is used? I have a couple of client certs in the local computer certificate store, could that be the reason? How can i tell the AnywhereUSB Manager which client cert to use?

Any help appreciated,
Mark

I checked the client certificate which is located at C:\Windows\System32\config\systemprofile\AppData\Roaming\AnywhereUSB\awusb_client_cert.pem and it looked fine so I figured that the issue is likely on the Hub side with the client certificate thumbprint not being registered on the hub for some reason.

As a test I tried copying over the certificate from the other VM and it worked.

Eventually I was able to resolve the issue.
I was restoring AWUSB Manager to its default settings and also deleting the client ID.

Then I deleted the client ID configuration on the Hub and rebooted the Hub.

While it was booting i configured the ClientID and Known Hub again in AWUSB Manager.

After the reboot was done my ClientID got automatically registered because I had the
“Automatically Register Unknown Clients” option ticked and everything was working fine.