AWS not posting all data since latest update

Using Net+O/S to latest modification level, running on Connectcore 9215.

I have a web page using AWS which has worked for years - it uses a little Javascript to update two hidden fields, and the form is then submitted to pass these values.
Since the latest update (to V1.02 of AWS package) this process fails, at least using a recent version of Firefox (V26, V27). According to Firebug the POST values are being sent correctly; however AWS only sees one of the values (the second field defined in the HTML is a zero length string).

Interestingly, the page still works with Opera 11 and 12 (but not with Firefox V13).

Has anyone else seen anything like this?

Have you tried other browsers such as IE, Safari, chrome? IF so what are the results.

Don’t have any of these to hand - used to the idea that Firefox ‘just works’!

Have discovered a couple of things:

  1. It appears that only the first ‘POST’ parameter is actioned by AWS - others are totally ignored (I had two parameters, added a third)
  2. Reverting to the 1.01 libraries fixes the problem.

Firebug implies that the browser sends the parameter list using ‘&’ separators, thus:
Having read the description of the 1.02 update, it says “Added a Null terminator to referer header when it sees any special characters”. I wonder whether either the scope of this is larger than it should be, or whether ‘&’ in the parameter list is being replaced with a Null, truncating the list.

For information, the most recent AWS update (V1.03) fixes this problem.