BSOD - Win 7 Pro - Edgeport/2 (RS232)

I’ve been using and recommending edgeport USB-Serial converters for sevveral years without issue.
Predominantly running on Windows XP and more recently on Win 7 Ultimate.
I have just connect my device to a Dell Vostro running 64 bit Win 7 Pro.
Drivers installed automatically without issue and COM ports evident - however as soon as I connected a USB device i got a dreaded BSOD and message referring to nusb3hub.sys.

I installed Edgeport configuratio utility and can confirm following drivers installed:
edgeser64.sys - 5.30.02 - 05/05/2010
ionenum64.sys - 5.00.03 - 12/18/2008
edgecoin64.dll - 5.00.03 - 12/18/2008
impscoin64.dll - 5.00.03 - 12/18/2008
edgeport64.exe - 5.58.5 - 03/30/2009

If I run the ‘test ports’ option in configurator this invokes the BSOD.

I have downloaded latest drivers from Digi site but noted they are now newer drivers than I have installed.

Help I am currently working on a project in Frankfurt and unable to complete until I can establish a serial connection with devices under test.

Are there any later drivers available to trty - Beta will do !


Hello Pete,

Is the Edgeport connected to a USB 3.0 port?

Hello Jeremy,
Yes I’m running a Dell Vostro 3350 which has 2 x USB 3.0 Ports only !

There’s a bug in the current release v5.30 Edgeport driver that can cause a BSOD to happen when the Edgeport is connected to a USB 3.0 port. We believe we have fixed this bug in newer drivers. Below is a download link to a newer beta driver that should have the bug fix. You are welcome to try it out until we officially release a newer driver. To update the driver, first uninstall the existing driver by running the Edgeport Configuration Utility and then clicking the Advanced tab and the Uninstall button. Reboot the computer when prompted then follow the normal installation procedure.


I am running into exactly same issue with edgeport/8r, I can’t seem the access the beta driver download, could you upload it again? thanks. I have win 7 64 bit and driver version

I have the same problem and I can’t seem to get the beta download to work. Can you give us another link?

Our FTP servers changed recently. Here’s the new link:


your link is dead… Seriously guys… 6 months?

I can haz beta?

Switching from a USB 3.0 to a USB 2.0 port fixed this issue for us, using version

I deciphered to March 6 2012 posted link, hunted around, and found the zip. is in the /EP directory of:
The username seems to be: jmcbane_ro The password: 1readonly!

I have not tried it yet with my Edgeport/4 connected to a USB 3.0 yet.