edgeport/1 windows XP crash

I have a edgeport/1 and download the driver from digi web site but I have downloaded Edgeport (RS-232, Compact) USB 5.30 And when I tried to open my serial connection session, windows XP crashed. My aptop is HP 8540w.

One of my friend has used the same edgeport in his laptop but used the original CD for driver and he has no issue with connection. Then I tried to uninstall driver and reinstaal from CD but I still have the same issue. When I connect edgeport then open serial connection session Windows crash.

Is there anyone who has the same issue? I think windows couldn’t uninstall all drivers and regedit entiries so I can’t install CD driver properly. Any idea?


We aren’t aware of any bugs in the current release v5.30 Edgeport driver that should cause bluescreens. With that being said, maybe there is some 3rd party firewall interfering. Do you have anti-virus software running on that computer?

well Both (mine and my friend’s) computer has same windows image and same antivirus package. Trend micro officescan. Is it the correct driver that I have downloaded? Edgeport (RS-232, Compact) USB ??

The CD has 4.20 release of the driver…

All Edgeports use the same driver. Disable trend micro and let me know if the bluescreen still happens.

Well since this is my company’s laptop and image I cannot disable the antivirus. But my friend’s laptop has the same image and antivirus and he is able to connect via edgeport/1

is there any ports known ports that edgeport use? SO maybe I can check these ports if they are blocked by firewall…

The only port that’s applicable to an Edgeport is a COM port, which is a way to identify a serial port.

Firewalls apply to network devices, and the Edgeport is not a network device, so that’s not applicable.

Maybe you should try the older driver that your friend is using without issues? To downgrade the driver, run the Edgeport Configuration Utility, click the Advanced tab, then click the Uninstall button, and reboot the PC when prompted. After Windows loads, install the older driver by pointing the found new hardware wizard(s) to the disc.


My problem has been fixed. The problem only occurs if I connect edgeport to laptop’s USB 3.0 ports. I have tried with USB 2.0 ports and connection established successfully.

So edgeport is not supported by USB 3.0 ports.

Thanks for the update.

We actually have a new beta Edgeport driver that should fix this issue.


If you want to try it out, download the appropriate driver (64 is for 64-bit OS’s), unplug the Edgeport from the PC, paste the newer beta driver over the existing one in \system32\drivers\ (overwrite/replace it) then plug the Edgeport back in. Does that help?

Yes it fixed the USB 3.0 problem. thanks…

I am a bit late to the party but I have someone complaining of the same exact problem with an Edgeport/1 (301-1001-15
) and her HP 8540w running Windows XP Professional when plugging into the USB 3.0 ports…tried to download the “beta” driver (in the May 6 2011 post by jeremym) but couldn’t connect to FTP site…is that file still there? Anyway, I have been using driver package 40002537_H.exe; is that the latest and greatest? Thanks!