Edgeport /4 - 64 bit windows 7 driver not working properly

I keep getting crashes with windows 7 64 bit. The driver loaded with windows update. If I use the configuration panel to adjust the Edgeport, I get a BSOD crash. The 4 ports show up in device manager with question marks. Any suggestions on getting this working properly?


1 Like

The BSOD might be happening because you’re trying to “use” the Edgeport before it’s fully installed.

Right-click on each of those Edgeport components in Device Manager and choose the option to update the driver, then either browse to the location of the driver (i.e. on the disc, or if you downloaded it) or you may be able to use Windows update.

Repeat that procedure for all of the Edgeport-related components in Device Manager until there aren’t any more yellow warning icons.

The System Status LED should be blinking green at that point.

Then run the Edgeport Configuration Utility and let me know if you have any problems.

Just completed the install as you recommended with new 5.3 64bit drivers in Windows 7. Went perfectly. All tests passed. No crashes.



Just installed an edgeport/4 usb on a Windows 7 32 bit machine. Used the most recent driver 5.30 en manualy updated the driver for every serial port. Everything works fine, but when shutting down or restarting te machine I get a BSOD with IRQ_NOT_LESS etc. Tried uninstalling an reinstalling, but with no luck. Does anyone have any idea? I have never had problems with Win2k or XP with this device, just now with Win7.

Hi Philip,

Is there a .sys file referenced in the BSOD?

Hi Jeremym,

There is indeed a .sys file in the BSOD. Can’t remember exactly which, but I will get in touch with my client tonight and let you know. It was however clearly one associated with the edgeport. Something like edgeusb.sys?

Meanwhile, thanks for the quick response.

Have an older Edgeport/4 which worked great under XP SP3. Upgraded that machine to win7/64, and I can’t get the thing to work.

Initially, the win7 installation just left the Edgeport with the yellow mark next to it in Device Manager.

I’ve downloaded driver 5.30, and unzipped to a folder, but Device Manager can’t find anything suitable in there when I ask it to Update Driver for the Edgeport.

So then I unzipped the .CAB file, and ran edgeport64.exe, which tells me No Devices Were Detected no matter how many times I hit Refresh, even though Device Manager sees the Edgeport.

The Edgport’s red LED is blinking at about a 2-3 Hz rate.

Stuck, any advice appreciated.

So I found the solution, if anyone runs into something similar.

The Edgeport/4 I have is an older model, and so edgeport.inf didn’t have the correct entries to recognize it.

I edited the following line to make it work:

; 1st Generation (930) VID/PIDs
%Ep4DeviceName% = Edgeport.Install, USB\VID_1608&PID_0001

to become:

; 1st Generation (930) VID/PIDs
%Ep4DeviceName% = Edgeport.Install, USB\VID_1608&PID_0c01

The third from last character on the line was changed from a “0” to a “c”.

Once I did that, and had Windows look in that folder for a driver, it found it.

I edited the 64 bit section since I’m using a 64 bit OS. Were I using a 32 bit OS, the same line exists in the 32 bit section and needs the same edit.

While the light is now flashing a slow green n the Edgeport, and I can see the modem and talk to it in test mode, I can’t actually use it yet because I keep getting a spurious (and inaccurate) error message that something else is using it and has to release it first, but that, I think, is a different matter.