Can I get help getting started with RCM5700 Standard Development Kit?

I have a RCM5700 Standard Development Kit with a MiniCore RCM5700, Interface Board, Prototyping Board, Digital I/O Demo Board, and RS232/485 Board. I have followed the instructions in the Getting Started guide, and am not getting any response after attempting to RUN the sample program (PONG.C). The Dynamic C compiler seems to function fine, and is able to detect the presence of the processor. The red LED side (marked TX) of DS2 flickers during the compilation during both the initial load and compilation steps, so it seems to me that the code is getting downloaded to the RCM5700, but no STDIO window opens up on my computer. If I use a terminal program (PutTy) I am able to establish a connection but the cursor just sits there. Furthermore nothing happens to DS2, and I’d expect it to blink at least a little.

I’ve also tried compiling and running the simple LED flashing programs, but other than DS2 flickering during compiling there’s just no signs of life. I have a feeling that I’m missing some very simple configuration step, but I have no idea where to look.

My computer is a Dell Latitude E5440 running Windows 10, and I’ve tried removing and replacing the jumpers at JP1 (1-2, 3-4, 5-6, 7-8) with no apparent effect. I’ve configured the communication settings at 9600, 8, 2 stop for the debug baud rate and have set the maximum download rate to 57600. I’ve also tried enabling/disabling processor verification and “Use RS232 to Serial Converter” with no impact.

What am I missing here? Is there some simple code to at least see if the RCM5700 is able to run a simple code with some response from the IDE? Any help is appreciated!

What am I missing?

  • Keep the default baud rates for the download (460kbps) and debugger (115kbps). 2 stop bits and both checkboxes (processor verification and USB).
  • Does CTRL-Y (Reset Target and Compile BIOS) identify the board as an RCM5700?
  • If you compile to the target, you need to hit F9 (Run) to actually start the program running. PONG will automatically open the STDIO window of the IDE.
  • Jumpers should be default 1-2 (enable debug interface – remove to run program without IDE connected), 5-6 (LED on PD0)and 7-8 (switch on PD1). I’m basing that on an RCM6xxx baseboard, but I believe the JP1 connector is identical on the RCM5xxx baseboard (which has some slight differences related to the Ethernet wiring).
  • Look at Samples/RCM5700 for samples specific to that hardware, including some that flash the LED. If you download that to the board, disconnect the 1-2 jumper on JP1, and then reset the processor, it should start flashing the LED.