Cannot enter command mode with XBee Pro 900 (XBP09-DM / XBP09-DP)

I have a pair of XBee Pro 900 (RP-SMA) modules. At one point, I had them both working fine, using two different adapters (one is a Parallax USB Adapter, the other is an adapter from AdaFruit with an FTDI USB adapter).

The working module works fine, will accept a firmware load of either XBP09-DM or XBP09-DP, and correctly responds to the +++ command to get to AT mode, and works fine. It responds to the Test/Query command in X-CTU as well as the modem read/write firmware, etc.

The broken module does not respond to Test/Query at any baud rate. Read firmware fails. Write firmware succeeds! But after writing, it is still not able to enter command mode.

Things I have tried so far:

  • Multiple known-working adapter boards
  • Wiring the module up manually using an arduino as the FTDI adapter, hard-wiring DTR, RTS, Power, and Ground
  • “Resetting” the device by tying pin 5 to pin 10 (RST to GND) and releasing. I tried both a short reset (1s or so), as well as holding the reset for > 10s.
  • Tried getting into bootloader mode through various means (resetting the device and entering the “B” command into the terminal). The bootloader menu does not show up.

It’s not in API mode as far as I can tell - I have certainly not turned that on intentionally, and I have re-flashed the firmware with API mode disabled to no avail. I have tried all normal baud rates.

Looking for any suggestions you can offer! Thanks

Contact Digi Technical Support, they may be having some ideas to overcome this. Create an ONline Support request at the following link, .
If the issue is already solved please update the forum