XBEE S3B won't enter command mode?

Hi to you all this is my first time on the forum so please take it easy on me if this is simple. Okay so I have 3 xbee’s
XBP9B-DMSTB002 rev E I am trying to connect to them in X-CTU and am having no luck.
I have tried all baud rates, resetting them through pin 5-10 connection, tried different parities etc etc any settings I can think of including the programmable ones.When I looked up the serial number I found they were programmable ( I believe this to be true)
I have tried a several new usb cables into my xbee breakout board. I then suspected the breakout board (all three of the xbee’s are giving me no joy and they can’t all be bad?) I have used an ftdi cable to serial dout and din and passed powe rot he unit from an arduino delivering 3.3v (approx). When I minicom into the unit and attempt to enter command mode +++ I get a message back.



F-Update App


V-BL Ver.

A-App Ver.



Does this indicate the unit is functioning and what and how should I be setting it so that I can get onto XCTU with it. I also don’t seem to be able to choose an option here?

Thankyou in advance for any help you can give.

This is a programmable modules. you must put it in Bypass mode on the freescale processor first before you can enter command mode on the RF processor.

HI there,
Thanks for that, I’m getting the bypass message but then nothing, I have tried entering b and B but then I cannot give +++ command to enter the command mode. A bit of googling on this hasn’t helped me to get there either. Do you know how I should then enter command mode? I have tried both ways, minicom and X-ctu (selected programmable module, set baud rate to 9600 , same as when I get comms on minicom) but it will not detect module? Is there once again something really obvious I am missing?

Hi all have since discovered the following:
The bypass mode does work but the RF side was operating at 115200 bd although the freescale was at 9600 bd. I think this meant it was trying to connect but couldn’t change bd mid way through to set up comms with rf side. I have now changed bd on other processor to 9600 and we’re good as gold.
Thank you for pointing me in the right direction, also found this helpful: