Unable to connect to S3B with XCTU

Currently using XCTU V6.1.1 and trying to connect to my 900HP S3B (XBP9B-DMSTB002 revA). I am unable to connect to either one. I am using the XBee Explorer board from Sparkfun and have already removed the RSSI LED from Pin 6 as to not put the module into diagnostic mode. I have also already optimized my USB settings for that port.

I know the Explorer board works because I am able to connect to my other XBees, all of which are the 900 Pro ( XBP09-DPWIT-156 revC).

When initially trying to connect to the module, it asks me to reset. I have the explorer board pinned out and a momentary button in place to handle this. I know it is working because during the reset request, I see the RX LED flashing and when I press the reset it stops while the button is held down. The dialog in XCTU never goes away and fails to connect. I have also tried the recover process but fails and states there is not active bootloader present.

I have also tried to pull the DIO pin to ground and to “wake up” the module if for some reason it is asleep. The funny thing is I got one to connect after about 50 attempts.

When I try to connect with a terminal to send AT commands, I get the following result.

Me: +++
Xbee: B-Bypass
F-Update App
V-BL Ver.
A-App Ver.

If I select Bypass there is not response and the module stops responding. I cannot connect with xctu after doing this.

If I select Update App I get the C character waiting for the binary but I have no way to send it since I cannot connect with XCTU. Using putty by the way.

Timeout does nothing.

BL version actually prints out the version. HA something works.

App ver replies back unknown

And Timeout just freezes.

Well any help would be awesome. Thanks.

You are having issues because you have a Programable module and not a standard module. You have two write and load an application on the 2nd processor before you can gain access to the RF processor.

I thought using the bypass option would allow me to access the RF module, or at least be recognized by XCTU. Thank you for the input, and I will start looking for starter code to get it working.

Well, back again and still no luck. I have downloaded the Getting Started zip and tried to follow the instructions found here http://www.digi.com/wiki/developer/index.php/Programmable_XBee_-_Getting_Started. They are horribly out of date and do not match up with the current version of CodeWarrior. I have no other programming gear other than the XBee Explorer board, so I was hoping to be able to just send the binary using the terminal. I am able to build the project in CodeWarrior and get the App32T.abs file. After sending this I do not see any change in the behavior of the module.

You will need to Enter the bootloader again as you did above. Then you will need to choose the upload option. Once in the upload function, use the xmode feature in XCTU’s terminal tab to upload you bin file.