XCTU Cannot Connect to Xbee PRo S3B

Hello Digi Members,

I just purcahsed a XBee Pro S3B and a Parallax USB Adapter, everything is nice and soldered into place :slight_smile:

However my XCTU is unable to test/query the XBee Pro. I have use my breadboard wires to connect the VCC to the Reset Pin, which causes the slight flicker in lights (as XCTU suggests in the popup) however it still does not connect.

When I attempt to Read the X3B:

Failed to enter command mode 
Check connections and try again. 
Read parameters..Failed.

Current Settings are:

Baud: 9600
Flow: None
Data: 8
Parity: None
Stop Bits: 1

I have tried API on and API Off, to no change in messages.

Computer Settings:

Windows 8 Pro
Default Found and Install Virtual Com Port Drivers
USB 2.0
Parallax USB Drivers
CDM 2.08.24 WHQL Certified Fidichip drivers

(I have run XCTU in windows 7 compatibility mode, and I always run as Admin.)

Any suggestions as to my next step in overcoming this initial hurdle?

Hello Jacob,

Try with 115200 bps (or other baudrates…) and let us know. Have you been able to access the device from other PC? Also, you can read the serial configuration remotely from other device in the same NetworkID. Best regards,

I have tried other baud rates, I can get the +++ to return OK. The network works and devices will communicate, however they refuse to enter ATAP2 mode.

Hello again Jacob,

Try to change the setting with X-CTU but from Modem Configuration tab. Were you able to set any other settings? Are you using the latest firmware version for your module?

Best regards,


Just wondering if you ever got your XBee Pro S3B and a Parallax USB Adapter to work with XCTU?

I have the same problem?