Cannot reach ME

We tried to communicate with the Digi Connect ME witch several Computers (Windows98 and Windows2000). But the Program Digi Device Discovery always tells “No devices found”. Also the Dos-based Digi Programmer does not find the Connect ME. Is it essentially to connect the Connect ME to a serial port? Is the Connect ME configured with an IP-address when delivered?


Yep, Im having the same problem. I had connection issues and decided to reset to factory defaults. Now I cannot connect at all. Tried x-over cable. Tried to activate DHCP on my router. Nothing

What am I to do??? This is already a 3 days wasted.




The Connect ME does not ship with a configured default IP address. It does, however, ship defaulted to attempt DHCP and RARP for address configuration.

Are you connecting this ME to the network via a Ethernet hub/switch or are you attempting to connect directly between the module and your PC with an Ethernet cross-over cable?

When powered up and connected to the network is the network Link LED (green) lit? When you attempt to force the discovery tool to refresh do you see the Activity (amber) LED light up at all?


We connect the Connect ME to a PC via an Ethernet Cross Over Cable.
I think you mixed up the LEDs. When powered up and connected to the network the amber LED lits. Then the green LEDs lights up for 3 times (I think this means that the operating system of the Connect ME has started all right.).
And when I force the discovery tool to refresh then the green LED lights up for a very short time. But the Connect ME is not found.
We also tried to reach the Connect ME by giving it an IP address per DHCP-server. But this is also not working.



Be sure that the Computer you are attempting to discover from has a Static IP assigned. With Windows 2000/XP/2003 they all will expire a DHCP address when they lose “Link”.



I’m having a similar problem too. My customer is trying to discover a Digi ME from a PC which is 3 switches down the line. Is there an issue with timeouts or anything like that? The switches are 2x Buffalo and 1x Belkin. Their Systems Admin assures me that there are no problems or conflicts on his network. Is it possible that he may have to enable a protocol such as SNMP or something like that? I’m just stabbing in the dark at the minute, any help you could provide would be extremely useful.



Try disabling DHCP and put a static IP into appconf.h. This solved it for me. I just assigned it an IP out of the range of the DHCP server that was still valid ( Seems to work without a hitch now. (Knock on wood)


how can you reset Digit Connect ME to default factory settings, I can’t even reach module???

I am using Net+OS version 6.0.

We noticed that if the Digi was set up for DHCP, it would hang if it could not find a DHCP server. So, this is what we did:

In bsproot.c, there is a while loop that sits there waiting for TCP to configure itself. It basically will stay there until DHCP is found. Add a timeout to the while loop so you can continue without finding a DHCP server:

while (ip_configured != IP_STATE_CONFIGURED && timeout++ < 3000  )/* wait until stack has IP parameters */
    tx_thread_sleep (1);    /* let other tasks run */

later on, though, your program will need to detect if you have an IP address or not. Then determine which direction to go (static or retry DHCP).

What type of module? Old, -C, or -S?

Old or -S types you can come in the back door, so to speak, by using the diagnostic mode from the serial port to access the network.

There are a dozen threads here that talk about that.


Impossible to connect my digi connect me, i have only module (without development board) and try winth xover cable and DHCP over router, and normal cable over Swich and xover cable over my Windows XP with DHCP server utility…i tired…only an all times flashin two leds!!
and the digi utility no found!!


What is the part number on the ME module you are having trouble with? Also, what tool are you using for device discovery?


the pN is (1P) 50000866-01J and i am using Digi Device discovery tool.

I recover my digi connect me, and i discover and put ip manually, the problem are the power, i connect with another power via LM1086 and all ok, but when i try the update de firmware 82000856_b to 82000941_b the connect me not discover and the green led pattern is 3-4-6 what it is the problem, (i upgrade via web).


DOH! 82000942…You have uploaded firmware for the Wi-ME, into your ME. I suppose that would explain things a bit, the device probably won’t run with the wrong firmware programmed into it.

Time to contact technical support.


How i can repair, i am contact with suppor the last 15/10 and dont have response about the repair the firmware!..ooooh

I fill
form to request services.



When did you submit the online support request? I have not seen your name come in on a request.

The procedure you are looking for can be obtained via our support knowledge base, at the following URL: