Can't configure ZB S2B with X-CTU


I’m trying to configure several modules so I can create a mesh network. But, first of all, I’m only trying with two modules (one coordinator and one router) in API mode (2).

First, with x-ctu, I changed modules function set to coordinator and router API, respectively. It works fine, I can read all default params perfectly.

But, then I want to change some parameters as:

  • Router version 238C:
    JV: 0 to 1
    JN: 0 to 1
    BD: 3 to 6
    AP: 1 to 2

  • Coordinator version 2170:
    BD: 3 to 6
    AP: 1 to 2

So, I write this parameters, with ot without, mark ‘Always update firmware’, it doesn’t care, but when I reset the module and read again the parameters, all of them seem erased.

How can I configure these parameters in a right way?? Which is the problem that makes it doesn’t write memory correctly?

Because of this, I can’t establish communication between modules without doing this first.

Thanks in advance!!

Ah well, the answer is as you say … you need to ‘write’ them :slight_smile:

I assume you are using the Remote At Command frame? the problem is your settings are just held in memory. They are NOT applied because often you need to set more than one things. For example, both the baud rate and PAN ID. It the PAN ID were to change before you got the BD in there, you’d lose contact and never be able to complete your sequence.

So there is an ‘AC’ command which tells the remote Xbee to go ahead and apply (in 1 action) all outstanding command are applied. But these are still just memory copies.

Then the ‘WR’ command will save them to flash.


I spotted some valuable information regarding mesh networking for wireless networks at Take a look, you just might find a wealth of helpful information from both the technical and business sections. All the best.



All modules are preconfigured as AT Command mode, but I want to change them to work in API mode (2).

When I did these changes, they lost their configuration. But if I restore them, they appear with some default values as API mode (1) and baud rate at 6 (57600).

I don’t understand why is this happening, if I wrote parameters correctly.