Communications problems with USB cable

I have been successfully using the Rabbit serial cable via a DB9 port on my docking station to flash RCM2100 cores. In an effort to avoid having to lug the docking station to the field (my computer has no DB9), I purchased the USB cable. As mentioned in another post, I downloaded the driver (CMD 2.04 16) from FTDI. The cable installed without issue. After configuring the Com port in the Rabbit Field Utility (v. 2.33) attempts to flash the 2100 result in the Coldloader message “No Rabbit Processor Detected”. I have tried configuring different baud rates on the port and RFU, still no communcations. Anyone have an idea as to what I’m doing wrong?


The new USB Programming cable only works in Dynamic C version 9.62 (or later) or Dynamic C version 10.21 (or later), which is why it is not working for you. You might want to try the regular serial cable attached to the USB to serial converter we have on our website

Thanks Margaret. After disabling the “Enable Processor Detection” and “Use USB to Serial Convertor” options in the RFU, the cable worked perfectly. Maybe it shouldn’t since I never installed the Dynamic C that the sticker on the cable says is required, but it did. I should point out that I am not programming per se, only flashing two programs to the core. I am sure that I would need the Dynamic C were I programming.

After upgrading all drivers try with:

Project Options -> communications chang partity from 2 (default) to 1.