Connect But No Data

The two XBees can talk to each other because in X-CTU the ATND command returns details of both XBees.

The range test returns a “timeout waiting for data” message.

I am sure they are both configured the same, 9600, 8bits, no parity.

Since the transmitted message and the loopback are done within the XBees it eliminates my external connections.

That only leaves problems with the settings.

Can you suggest things I should check that affect the data flow please.

Info added the next day -

I have tried 2 new modules, the only settings changed from the defaults are the channel and destination address.
They also won’t pass data.

I set the destination address of one module to its own address and the range test works and the terminal shows key presses and their echo.

It seems like one of the default settings is blocking the flow of data.

Solved -

The problem was I was using the range test as a loopback test to test the data link.
Unfortunately it doesn’t create a ‘remote’ loopback, you have to go to the remote site and connect a hard loopback.

If you want a remote loopback test you have to create your own system that will connect a loopback external to the remote XBee.