Connect ME 9210 -C: no ethernet?

We found 30 devices (rev E, 2327 datecodes) from a broker, so I’m testing them out. They seem legit, and 29 accepted our flash test app, detected the new flash chip, and installed the patched application. But one never came online.

I strapped the pins to ground to force the TFTP recovery, but it never established an ethernet link. Used the xmodem serial recovery method to load our test app, which worked (slowly!), but still no link.

I’ve assigned it a static IP address, but it’s not replying to pings.

The only clue that I’ve seen in the serial output is a line about a lost IP address:

  IP address on LAN is
  LAN interface's subnet mask is
  IP address of default gateway to other networks is
  Primary DNS server address is
  Secondary DNS server address is
  Serial channels will use a baud rate of 9600
  This board's serial number is N99999999
  This board's Ethernet MAC Address is 00:40:9D:DD:C1:CC
  After board is reset, start-up code will wait 5 seconds
  Default duplex setting for Ethernet connection: full
Press any key in 5 seconds to change these settings.

Serial CLI Started
IAM:STATIC IPv4 on eth0
IAM - lost STATIC IPv4 address on interface eth0
Network IP configured.
FTP server started.
HTTP server started.

Any thoughts or suggestions? There’s no obvious physical damage, and the very same network cable, switch, and dev board worked fine for the other 29.


is there LED activity when you plug a cable? Is the ethernet if you force it into bootloader recovery? If not, I’d say it is broken. If it is still within the return period, return it to where you bought it or make them replace it.

Thanks for your comments!
No ethernet link at any time, in either the factory app, our app, or the recovery app.