Connect Wi-Me -C

I’ve got an application on a Wi-Me -C which use DHCP to get an IP address.
When my access point is ON, my application is starting and working properly. But when the AP is not ON, then the application doesn’t start. It looks lile the module is waiting for an IP address in order to carry on.

I would that my application start even if my AP is not ON.
Any suggestions ?

Thanks for you help

I’ve found my problems by enabling the Auto-IP.

But now, I’ve got another problem.

When the module lose the DHCP (for example by switching off my AP) I’ve got the following message on my debug port:
IAM - lost DHCP IPv4 address on interface wln0

But when I turn ON again my AP, it looks like my module can’t reconnect to the AP.

Any suggestions ?


I believe the Connect Wi-Me -C uses NET+OS (?) if so what version of NET+OS?

I’ve done some amount of testing of wi-fi enabled devices with APs. Generally I recommend turning off ALL encryption and authentication. I also recommend getting the AP close to the device that is trying to associate with the AP. By turning the AP off and on, you are essentially testing roaming (in a matter of speaking).

So I’d start with no authentication and no roaming and the AP and device close together. See if that works. Then start adding in authentication, encryption and distance to see where things stop working.

Also what brand of AP. We have had more luck with the better known brands then with the lesser known ones.

I dakotas dad,
I’m using NET+OS 7.5

The problem happen (development board) with the Connect Wi-ME -C with JTAG.

When I’m using the Connect Wi-ME -C without JTAG , it works fine.


Some of the questions I asked before…

What brand is the AP?

Have you tried with encryption and authentication off?

Are you up to date on all patches?

How close is the AP to the Connect Wi-ME -C? If far away, can you bring it closer and retest?

Are you running from the debugger or from FLASH?

Is the AP’s firmware up to date? We had some issues with a less-than-known brand AP until we upgraded its firmware.

You are sure you are set up for infrastructure as opposed to ad-hoc mode?

You are sure you have the SSID correct?

Another thing you can look at, is the set up for a single channel or is it in scanning mode (0). Try setting to the channel that the AP is set to. Does that help?