How to reset device to factory defaults

I have the Digi Wi-ME Integration Kit. I attempted to place the Wi-ME on the Integration Kit board, and powered the board while holding SW3 (which appears to be tied to RESET) for 20 seconds. This apparently did not do the trick as the device discovery is still not finding the device.

The User’s Guide says to refer to the ME Hardware Reference for details on hard or soft resets, but I find nothing in my hardware manual related to hard or soft resets.


Incidentally, I have a private AP with authentication and encryption disabled.


1 Like

Also tried placing a jumper on pins 2 and 3 of P12 and then powering up the device. After approximately 15 seconds, I get a 1-5-1 blink sequence on the yellow LED. “Getting Started” documentation says to expect 1-5-1 on green LED.

The Wi-ME’s MAC address is appearing in the list of wireless clients on my router’s status page, but no IP is being assigned still.

1 Like

What is the condition of the WI-ME’s amber (yellow) LED? Is it on solid (indicating an infrastructure association), flash slowly (indicating an ad-hoc association) or fast (searching for a network)? As you state the device is listed in the APs client list I would assume it is on solid, I would like to confirm nonetheless.

Do you have a DHCP server setup and running on the network? Does the server have enough available leasable IP addresses to support one more client?

What brand, and model, of access point is involved here? Have you checked to see if there is a firmware update available for your AP? I have dealt with more than one wireless issue that was resolved by an update to the AP firmware; this is not to say that this is the problem here.


1 Like

My AP is in infrastructure mode, and the amber LED is on solid. I do have a DHCP server up and running, and it is configured to lease 50 addresses with only 6 currently being used.

I have a Linksys WRTG54G v4. I am running the open source DD-WRT v23 SP2 firmware on the router (also the SSID is ‘Connect’)

The Wi-ME was previously configured to access a network with WEP encryption, which is why I assumed it wasn’t receiving an IP lease. That is why I was attempting to restore it to factory defaults. If the device was still trying to access an encrypted network, would it still show up in the client list? Do I have reason to believe the Wi-ME HAS been restored to factory defaults even though I got a 1-5-1 blink sequence on the amber LED rather than the green like the ‘Getting Started’ guide suggests?

1 Like

By performing the reset procedure, as you have described above, the unit will reset its configuration back to ‘factory’ defaults. A point should be made here, however, that although Digi has a set of defaults, i.e. SSID:ANY (Connect preferred), no authentication, no encryption, etc.; it is possible for these modules to customized so that its ‘defaults’ can be different.

For the sake of this discussion, I will assume that you have not customized this module.

Performing this reset will reset ALL stored configuration, including IP address, SSID, wireless Authentication, encryption, etc.

My suggestions are as follows:

  • Assuming that your DHCP server is part of the APs firmware, disable it and use an external server, there are a few freeware/shareware servers available.
  • Configure the Wi-ME to use a static IP address; you will likely have to either use another AP or a wireless PC, in ad-hoc mode in order to access the Wi-ME’s web configuration.
  • Restored the default Linksys provided firmware on this AP and see what happens.
  • Try another brand/model of AP. This would not be necessary, assuming it is posible to restore the original firmare to you AP.

We have tested our firmware against the WRT54G Linksys router. I have also spoken to a number of customers succesfully using this AP, as well.

One final option which may provide some insight is to generate a network capture, from the wireless side of the AP would liekely be easiest. Review the trace and look to see if you see DHCP Discover packets being orignated from the Wi-ME. Also take a look at the packets and ensure that the contained contained therein looks to be ‘sane’.

About 1-2 years ago I worked with a customer having similar problems; the issue turned out to be a pointer problem with the Linksys firmware. This problem manifested itself in the DHCP Offer packets it sent out. Instead of valid configuration data the offer contained information regarding the APs configuration, i.e. admin password, route table, etc. The DHCP Offer packets were also much, much larger thatone would normally expect. Not to say that this is your problem, it is something to take into consideration.

1 Like

I restored the DD-WRT firmware to its defaults, and the Wi-ME now gets an IP address and is fully functional. I wish I could provide more information on what exactly caused the problem for future reference, but I simply have to shake my head in puzzlement…

Thanks for the responses though, Cameron.

1 Like