Connecting to iDigi with eth0 on an X4H connectport gateway

How does one disable the cellular mobile port on a Connectport X4H and use the eth0 ethernet port to connect to iDigi?

If you do not set up cellular (plus have no SIM, etc), then the Ethernet port just works.

If you do have cellular & it is active, but you want iDigi (or ANY service) to use Ethernet and not cellular, then you need to setup the correct Ethernet router-gateway information, then go into the “Network” settings and create MANUAL ROUTES to iDigi which tell the X4 to use Ethernet and not the default ‘router’.

It is on the “Configuration > IP Forwarding > Apply the following static routes (up to 16) to the IP routing table” section.

For example, i have to do this to connect to a WAN in a demo room because from my desk I see it as, but my PC will have IP If I try to open a web socket to the WAN, it sees the subnet mis-match and sends responses out cellular.

So I create a STATIC ROUTE for:

  • destination Network =
  • Netmask =
  • gateway address = (which is the Cisco firewall linking our corporate net into the DMZ demo room)
  • Metric = 1
  • Interface = eth0

This example is for a local IP, but the concept applies to an internet service - you just MUST be able to decode the DNS to an IP, as Ip forwarding doesn’t work with a DNS name.

Actually, to really clamp-down your cellular traffic. You can also do somewhat the opposite.

Under Network > Advanced Network Settings you can see that you can change the Gateway priority to be Ethernet, not ‘Mobile’. Then for EVERY valid cellular function, you need to create a manual IP route (as above). This prevents some device inside your system from treating the X4 as a ‘router’ due to mis-config. If this happened, the X4 would just forward via Ethernet instead of cellular. The mistake still doesn’t work, but you are not being charged for the traffic.