ConnectPort X4 factory settings producing issue

I recently successfully connected a ConnectPort X4 to the iDigi developer platform server. However, after having to restore my settings to defaults using the reset button, I am unable to connect to the remote server.
I ran the ping diagnostic tool, which returned the error “Unable to resolve the Hostname” for any addresses I attempted to input. Inputting an ip address directly produced the message “error: unable to open ping”. Apparently I am only able to ping addresses inside my own subnet.

Any idea what setting could have affected the remote connection? I’m 100% sure everything worked ok before I performed the factory reset.


Do one thing, Connect RS232 port of ConnectPort X4 and open the COM Port using hyper terminal. Now set IP settings using CLI command ‘set net submask=’ and then ‘boot a=r’. Now try to ping the set IP as the gateway restarts. This should work.

Thanks for the response. My problem isn’t however that I’m not able to connect to the device itself, it works perfectly fine through telnet or the web interface. The problem is that I can’t ping IP addresses from the device diagnostics although I have it connected to the Internet.

At the moment I suspect something got messed up in the Network settings while reseting the Connectport. Unfortunately I’ve no idea which setting.

Try setting dnspriority to eth0 and then static and other from the telnet command set net. You can connect to ConnectPort X4 using 232 serial port also and apply CLI command