HELP! Reboot timeout error with ConnectPort X4

Hello people, I’m having difficulty connecting the ConnectPort X4 from Digi development kit to my computer. I’m doing it for my school project so I can only connect it locally and not to the internet.

I’ve followed all the steps in this video: (except that I connect the ConnectPort X4 directly to my computer through the LAN instead of to the router, and skipping steps from 0:50-1:25 which requires an internet access)
http://www.youtube.com/watch?v=prtxwPbFDwo&feature=mfu_in_order&list=UL

However, there is an error when I tried to run it. (the part at 3:13 of the above video)
There is this pop-out:
"
[b]Error launching configuration

Unable to launch the selected configuration because of the following errors:

Reason:
Reboot timeout.

Increase the reboot timeout of the remote configuration ‘ConnectPort_X4’ under ‘Device Options > Device Manager’.[/b]
"

I’ve tried increasing the reboot timeout from the default 60s to the max. 240s but the problem still occurs. I’ve also tried both straight and cross-over cables but it doesn’t work either. My computer is able to detect the ConnectPort through Digi Device Discovery. Can anybody help me out? Thanks.

Is your ConnectPort is provided static IP or dynamic IP?

Check gwpriority using ‘set net’ CLI command. Priority should be given to eth0 first.

I hope you may not have provided gateway IP. If DNS server is turned on than disable it using WebUI.

I hope with this your problem should be solved.

Yes, my ConnectPort is provided with a static IP.
Usage of DNS server is set as none.

But how to check for gwpriority? Where do I open the CLI?

Hi,

Open the command prompt and type “telnet IPaddress of your device”
#telnet Ip.

Issue "set network"command, you can find gwpriority.

Regards!

Hi,

I’ve opened command prompt from windows and typed as you’ve said, but it shows:
‘telnet’ is not recognized as an internal or external command, operable program or batch file.
#telnet’ is not recognized as an internal or external command, operable program or batch file.

EDIT: I got the telnet working and priority is given to eth0, but I’m still having the reboot error.

I’m using Windows Vista by the way.
I also noticed that the ‘reboot timeout’ error occurs in the middle of the reboot time.
>> Launching (68%)
>> Launching: Waiting for reboot (58)
The time haven’t reaches 0 yet and the timeout error appears.

Is the DHCP server is Enable? Try disabling it and try again. Also provide static IP to your local PC.

I was able to get it work and running on my friend’s laptop. Do I have to change any settings(such as IP?) when I connect it back to my PC?

You shouldn’t have to change settings, as long as you’re using dynamic IP addressing and there is a device on your network that is serving as a DHCP server. Your typical “broadband” routers (wired or wireless) usually have this capability.

If not and you had the CPX set to a static IP address from your friends notebook, then you would want to make sure that your notebook is also set to the same IP as your friends (one that is on the same network as your CPX (all 192.168.x.x addresses).