"Connectport X2 ZB ethernet" says "The Xbee Network is not available"

Good morning,

I am having problems with three units of the ConnectPort X2D.
It appears that the Xbee driver is permanently disabled.
The webUI shows the message “The XBee Network is not available.”
If I try to read/write Xbee parameters using the CLI via Telnet, I get the message “Xbee network not available (Gateway is disabled, -90).”
I know the Xbee module is alive because if I try to communicate with it through XCTU+real port, I can do it without any problems.
Additionally, I can see that the Xbee module, which by default is configured as a router with an extended PAN ID 0, is able to join a Zigbee network.
I have noticed that in the three units with the problem, the HW version of the Xbee module is 2E4E. In the other units I have in the office, which work perfectly, the HW version of the Xbee module is 2E4D. I am not sure if this is related to the problem.
The FW version of the GW is 2.27.3, with Post 1.1.5.

Make sure that the baud rate on the XBee is set to 115.200bps and AP is set to 1.

Thanks for the quick reply.
Yes, I had already made sure that the Xbee module was configured to 115,200bps and the AP parameter was set to 1. I had seen that suggestion in a topic whose description was very similar.
But it didn’t help me. The values of those two parameters were already set correctly .

Is the Enable Gateway access enabled under the XBee network > Gateway access? If it is, disable it.

No, it is not enabled.

Something interesting I’ve noticed is that in the three units that are failing, I can access the Xbee module using XCTU+Real port without the need to enable that option.
It gives the impression that it always considers that option to be enabled, regardless of whether I have enabled it or not.

I would also like to add that I have tried the following:
Factory default setting
Restore Configuration (using a confguration of one of the units that is working)
Upgrade the firmware of the ConnectPort X2D.
Downgrade the firmware of the ConnectPort X2D.
But it did not help.

Try enabling this function and then disabling it.

Thanks, I had already tried this several times, but I tried it again, just in case.
It did not help.
In both cases (with function enabled o disabled) it says that “The Xbee Network is not available” but the message is slightly different

At this point, I would suggest going to https://my.digi.com and logging in. Then submit a case to Digi Support. Make sure to include all information possible including the devices serial number/mac address.

Thank you for the support. I will do so

Hi Eric, problem solved.
We have opened on of the GWs and as you can see on the picture, half of the pins were not properly inserted.

After inserting it properly, it works.
We will investigate it internally. It could be that the connector of the antenna was overtightened at some point.
I don’t quite understand why the XCTU+Real Port communication worked, but I’m not going to spend more time on it.

That would explain it.