Digi Xbee Industrial Gateway Not forming Xbee network

I recently tried to update the firmware on my Xbee Industrial Gateway remotely from XCTU but received a failure message. Now when I turn on the gateway the xbee LED does not light up green. I’ve tried to do a firmware update from the web interface, but it states “Firmware upgrades completed, but there were errors.”

What firmware version was installed on your Gateway before and what version did you try to load on?

I was running VERSION and tried to update to VERSION I’m unable to configure any xbee network settings receiving the message “An error was encountered while loading XBee network information.” and “Invalid address ()”

Aslam, XCTU is not capable of updating the firmware of a Gateway.

From the sounds of it, you updated the firmware of the XBee in the gateway. You will need to modify the settings on that module via a remote radio over the air as you did before. Just make sure you set the baud rate to 115200bps and AP is set to 1.

When I try to update local (gateway) Xbee’s firmware on the web interface I immediately get the message Unable to identify gateway address. I’m also unable to edit any network settings through the web interface as it tells me Invalid address ().

Aslam, You are not going to be able to modify the settings via the web interface of the X2. You need to add a second radio via an interface board and connect it to the PC. Then using XCTU, enable API mode and use the Remote Discovery option. XCTU User Guide