Digimesh 2.4 S1 will not connect to Digi Xbee Gateway

I am currently trying to get my Xbee 2.4 S1 devices to connect to the Xbee Gateway through the device cloud using the next gen X-CTU. So far I have been able to get my Gateway to properly connect to my Device Cloud Account, and am able to use Device Discovery to get into the Config Webpage of the Gateway.

I know what the PAN ID and channel the Gateway are broadcasting in, but when I set my Xbee to the same network, and use the Config Web page to Discover Xbee Devices, nothing comes up.

I have tried firmware updates on the Gateway, (I found them from the user manual of the Gateway) and they have gone through successfully.

One thing I noted from the Xbee 2.4 on X-CTU, they defaulted to firmware 8065 and will not update to any newer versions.

I am at a loss as to why my xbdm’s are not finding the gateway.

Any help will be greatly appreciated!

What firmwaer version is your XBee running on the Gateway?

The Xbee’s are running on firmware 8065. Whenever I try to flash newer firmware onto them through X-CTU, it brings up “retry connection or cancel” window and will not update the firmware

Are you able to issue an ATND from the modules and see the Gateway or any other module within the network?

Are you using any sleep settings on your gateway?

How far apart are the two?

Do you have antennas on both?

I am able to run ATND through X-CTU and got the response "FFFE ‘serial number and node id of the Xbee 2.4’ FFFE.

Other than the FFFE part, I understand that the one device is finding the other through its network. And after that I get

I am not sure what number that is, it does not match the serial number of the xbee gateway.

To answer your other questions,
I am not sure if the gateway is programmed to have any sleep settings, I looked throughout the configuration page and did not see any setting for that.

The Xbee 2.4 modules have antennas attached to them and also in the same room as the gateway. The gateway does not have an external antenna, but is able to wirelessly connect to the modem, that is how I was able to connect it to the device cloud.

Also as a side note, I have been able to update the firmware on the Xbee 2.4’s, they are now running on version 8070

The response should be similar to:

MY (always 0xFFFE)
NI (Variable length)
(2 Bytes) (always 0xFFFE)
DEVICE_TYPE (1 Byte: 0=Co
ord, 1=Router, 2=End Device)
STATUS (1 Byte: Reserved)
PROFILE_ID (2 Bytes)
Optionally included based on
NO settings.)

What do you mean by it does not have an antenna but you are able to connect to it on the Device Cloud. The X4 will connect to the device cloud via either the Ethernet, WIFI or Cellular connection. Not the XBee connection.

Thank you for your patience with me on this problem,I am new to using these devices.

I had misunderstood your question about the antennas. I thought you were asking if the gateway itself had an external antenna plugged into it. The gateway is able to connect through Ethernet and WiFi, however my connection from the internet to the gateway itself is via WiFi connection.

It could be that I am using the terminal commands wrong. Through the older version of X-CTU, I am able to start a connection with the terminal with “+++” and then typed in “ATND” and that was the response I was given. Is there another way to use the ATND command?

Also these Xbee’s seem to not have a MY address, I am not able to read or write an ATMY command because “ERROR” is always the response, I was able to update the firmware to 8070 but this is still an issue.

Other than issuing it in API frames, you have it understood.

That is correct. The MY field is a 16 bit address. When using Digi Mesh, the 16 bit function is disabled and you must use the 64 bit Serial number as the source address.

I am able to get the two Xbee devices to find each other, while connected to two different computers, by setting them to the same network listed on the Xbee Gateway Configuration and Management page, and I have set both devices’ DH and DL to the serial MAC address of the Gateway itself.

I also was able to put the XIG config files on the gateway in hopes that, that would help make them connect, but I am completely at a loss as to why they wont discover the gateway and vice versa.

Is it possible the Gateway Xbee firmware 0x4043 is out of date and that is causing the problem? I have tried to find updated .bin files, but I am not sure what to grab.

Why don’t you start with the Simple Hello world python script on the Gateway and send the data to the Broadcast address of FFFF. This will help you reduce the complexity a great deal.