Digi Connect firmware recovery problem

Due to an error while updating the firmware, I got 4 Digi Connect ME’s bricked.

I’ve unbricked one of these in the past using the TFTP method. However, this time around it seems none of the 4 bricked devices transmit any ethernet packages.

I checked this by running Wireshark on the same PC as the TFTP server, which was on an isolated network switch with the Digi modules. Connecting a non-bricked Digi module to the same switch showed me its DHCP requests, as expected.

I also tried the TFTP procedure while connecting either or both of pin 18 and 20 to ground.

The green LED seems to blink in a 2-2-5 rhythm. Any pointers to the meaning of this code?

Any alternative methods to try to unbrick? The modules are already soldered to their PCB, and its UART is wired to the application CPU, so it’s rather difficult to try the XMODEM method.

1 Like

I’ve seen the 2-2-5 before and recovered from it using the diags menu:

I’ve also seen 2-2-6. That one wasn’t recoverable. I had to RMA modules in that state.

1 Like

Thanks! This worked very well for me.

As the module was already soldered to its PCB, I had to reprogram the application CPU first, so it wouldn’t interfere with the UART signals. But otherwise, very straightforward and great solution.

This is about -S modules running Plug and Play firmware:

see also: http://www.digi.com/support/kbase/kbaseresultdetl?id=804
linking to: