Digi Connect Wi-SP will not re-connect to my wlan

Since last my wireless serial server devices are not connecting to the wireless network.

The devices are a digi connect wi-sp device used to transfer weight values from a scales to a serial port. The devices use a cisco leap authentication, with a username and password to join the network. I have tried to configure and reconfigure one of the devices, but it is still is not connecting to the network.
The deivce is currently configured correctly but shows a flashing green LED indicating it is trying to access the network. It flashes every second green. Any ideas??

The settings below are the default settings that the Digi will attempt to look for in an access point. Once the Digi is associated these settings can be changed, provided they are changed on the Digi AND the access point. At this point encryption and authentication can be setup.

ACCESS POINT SETTINGS (case sensitive):
SSID: Connect
Authentication: none (i.e. open)
Encryption: none
Channel: Auto (1, 6, 11 preferred)
Mode: Infrastructure (as opposed to Ad Hoc)
DHCP server: enabled

The Digi by default will look for an access point with an SSID of “Connect”. If it can’t find “Connect” it will then look for an Ad Hoc network with and SSID of “Connect”. If that fails it will then associate with the strongest unencrypted access point signal regardless of SSID. If there are more than one access point the digi will attempt to associate with the SSID of “Connect”, regardless of signal strength. The digi needs an access point without authentication or encryption. It will not be able to associate if either of them is enabled. It can associate with any channel but 1, 6, or 11 are preferred (assuming North America). The digi by default will look for an access point in Infrastructure mode. It will come up in “BSS_Join” mode.

Once the Digi has successfully associated with the access point its LED will stop blinking and go solid. Then after it associates, assuming that the module has not been assigned a static IP address, it will attempt to acquire a dynamic IP address from any available DHCP server on the network.

-Make sure the AP is running in mixed or “B mode” (802.11b). If the AP is running in “G Mode” (802.11G) only, the Digi module will not be able to associate with it as it can only do B mode (11 Mbps).

-If you continue to have problems, then try to force the Digi to associate with the desired access point. Remove the antenna from the Digi and move it within a few inches of the desired access point. Check the above settings on the access point. If you have any other access points in the area you might want to power them off.

-If the Digi is still not associating then try resetting the unit back to factory defaults (see users manual for procedure). Perhaps the unit has some other settings that are preventing it from associating.

-Check the modules Link LED. If it’s solid then that means is associated with an access point. If it’s blinking quickly (once every second or so), then it’s not associated but searching. If it’s blinking slowly (once every 5 seconds), then it’s associated with an Ad Hoc network.

-If the module’s Link LED indicates that the module is associated but you still can’t discover it; turn off the access point or Ad Hoc network. Does the green LED start blinking rapidly? If it does then that means that the module was associated with it. If not, then you know that the module has associated with some other wireless network.

-Make sure the module has the newest firmware loaded onto it. You can obtain that from Digi’s website.

-Make sure the access point being used has the newest firmware loaded onto it. In rare circumstances, errors in the access points firmware can impede communications.

-Run the module in “debug” mode (Digi Connect WiSP only). Flip unit over and set all red and white jumper pins in position so that they are closest to the serial port (on). Then attach a serial cable and open a terminal program from the PC or laptop with the following settings: 9600 baud, 8 data bits, 1 stop bit, no parity, no flow control. Then type the following commands:
set trace state=on
set trace mask=wlan:+cdiw

Then, the module should start displaying what access points it sees and which ones it’s trying to associate with.