dynamic C v10.11 "target communication error"

Hi to everyone,

I own the first release (10.01) of Dynamic C which was bundled with the RCM 4100 development kit.
This version does not return any error when I try to compile/flash the device with both serial and USB converter cable but returns a “divide by zero error” when I launch the DC 10.01 IO Config program.
For that reason I decided to update to the 10.11 version and here is the main problem.
Now the DC 10.11 IO Config works fine but I’m unable to compile/flash the device. The software recognise the device but returns a “Target communication error”. I tried to decrease the speed of the serial port as written on the manual but i still get the same error.

The PC I’m working on is a Desktop PC (all requirements to run the software are satisfied) with WINXP SP2 and a legacy serial port. I get the same error using an USB/serial converter on my new laptop.

I’m pretty sure it’s not a cable problem because the v10.01 can flash the device with both the serial port and the USB/serial converter.

How can I fix this?

Thanks in advance,