Edgeport/8 - can't install ANY version drivers for Win-XP SP3

I have read most of the relevant posts, about installation problems, spent two days trying various installs, but my Edgeport/8 (part # 301-1002-08) gets a Win XP (x86) error saying that it “can’t find the necessary software to install the hardware device”.

This Edgeport/8 unit has never been used before. First time install.

The same failure repeats with its original enclosed CD drivers (Rev H) as well as other older drivers Rev C, and Rev G, and Rev F. - downloaded from this site.

I point the installer to the zip expanded folder in the root directory, or in a user folder - no difference, can’t find “some necessary software”, which I assume it means - other than in the Edgeport driver folder.

The Edgeport installs itself perfectly, with the Win-7 Installer, when plugged into a Win-7 (x86) desktop system, finishes the installation, configures its serial ports, and the green LED starts its slow flashing, indicating the hardware and most recent OS software are fine - in Win-7. But I need this device for the XP laptop.

Odd that this Compaq NC-8000 laptop can’t install the Win XP Edgeport/8 drivers - and absolutely no clue which “software it still can’t find”. There have not been any other laptop or XP problems. Registry, garbage files clean-up, and Windows Security Essentials anti-virus runs every day on both PC’s.

Thanks for any clues.

SUCCESS at long, long last ! Found the solution. My Edgeport/8 RS-232 Hub is definitely a keeper! Glad I didn’t have to switch products.

Thanks to Jeff in Tech Support, for a lot of help trying to resolve this mystery. As I stated, the Edgeport/8 installed perfectly on several of my “other” PC’s and OS’s.

No problem with Win-ME, Win-7 (x86 and x64) … but none of the Installer revs would install on my laptop’s Win-XP-SP3 (x86). Windows kept saying that “Some driver was still missing” - of course it wouldn’t say which one, it’s for Microsoft to know … and for you to guess :wink:

A good clue was that not even a brand new “standard” USB 7-port hub would install on any USB port of this laptop - same Win-XP error message - and these are generally “dumb” devices, certainly never come with drivers. Support for a regular HUB is built into any version of Windows. Yet XP insisted on a driver file pointer.

This laptop’s upgraded disk was ACRONIS cloned from my original smaller drive, so pretty much still identical. So, I re-installed the original hard drive, Win-XP still untouched, and Edgeport/8 installed right away, like a charm.

Do a Google for" “xp usb hub installation problems” … you will find literally hundreds, if not thousands of threads, from people suffering from this problem (for Hubs, and digital cameras, mice, etc. ) – in fact ANYBODY who uses ANY kind of “external HUB-like device”, including not only typical USB 4 & 7 port hubs (powered and unpowered), but also any other “MULTI-Port” USB device. So, this can also happen with any variety of DIGI product, which is just another “Generic Hub-like device” to the OS.

Reading hundreds of web threads, there seemed to be several ideas, at least one proposed by Microsoft, and their VIP experts:

(1) Uninstall service pack, and re-install a fresh copy – tried that, wasted an entire day to get all the corresponding updates re-installed that came with it.
(2) Re-install Windows, assuming one has the CD - Very bad idea
(3) Since every other USB device, (e.g. thumb drive), works in any port, and no hub-like device will work with ANY one of them, then maybe the laptop USB electronics are damaged or weakened, and can’t drive the required 500 milliamps - a brown out condition. WRONG again, don’t chuck the laptop to get a new one - which would work, since it obviously comes with a fresh copy of the (perhaps same) OS.
(4) Check your hard drive for a missing USB INF file, and install it – either by extracting it from the Win Installation CD’s CAB file,
(5) or much easier, “borrowing a copy” from the WINDOWS\INF folder, in a similar working XP system.

That last one finally worked !!!
The problem had been that somehow, both files, got deleted from my laptop’s Windows (XP) system, perhaps by a virus scanner, or an overzealous registry cleaner, or a very tricky Trojan.

[size=3]These two critical files for “USB HUB” Windows support are:
C:\Windows\INF\usb.INF which is just a readable generic installation text file, and also
C:\Windows\INF\usb.PNF which is a compiled binary
(There are also similar pairs there for Printers and Video cameras, which can also screw up this way)

Without these present in the folder, ANY and all external hubs cannot be  fully installed, even with good "ancillary features"  drivers like the EDGEPORT support. You do need BOTH resources. For the most part, in such situation, typical USB hub-like devices,  simply remain  invisible to the OS. The DIGI EDGEPORT series might manage to install the DIGI software driver component, but without USB.inf, the client ports (RS-232. Printer, etc) cannot be connected back to the host ... because their PID (Product ID code) still remains invisible. That is why my Edgeport/8 was NOT being found, until I pointed at some  "other additional support Windows driver".

This took me a solid two man weeks, a a couple of all-nighters, to figure out. Hope this helps anyone else who suddenly finds their HUB “thing” won’t work, on any USB port in their system.