Error in updating Firmware: invalid image header


I’m working with the Digiconnect ME (in Win XP) only for a short time. Maybe my question is very simple to be answered. Here my problem:
I created a “image.bin” file with the gnu-compiler without any error. But when I try to load this file up to the digiconnect (with the “update firmware” option) it doesnt works and i recieve the message “invalid image header”. I tried also on of the digiconnect examples but with the same result.

I’m thankfull for every answer!
Greetings, Steffen Erkel


What version of the development kit are you using? Check line 2 of the provided readme.txt file. Digi/NetSilicon is current shipping (version 6.0e).

Also what is the part number on your ME module?

I suspect that you have used the incorrect platform when compiling your application.


First: Thank you for your quick reply!
The development kit version is
The Part Number on the digiconnect (JTAG) is: 50000866-02F

Bye, Steffen


When you built your BSP and the application what PLATFORM did you specify? I suspect that you did not use PLATFORM=connectme.

Perform the following steps:

  1. Rebuild your bsp; ‘make PLATFORM=connectme clean all’.
  2. Rebuld your application; ’ make PLATFORM=connectme clean all’.
  3. Then try to upload your application image.

You can verify the header of your application image using an editor application capable of displaying the image.bin file in hexadecimal format. Look at offset 0xC0-0xC3, which should read “Digi”. Offset 0xC8-0xC9 should read “OS”. This is solid sign that your image has the correct header.


I’m running into this same problem. I’m using patched NET+OS 6.3. There is no “Digi” at offset 0xC0. There is “bootHdr” at offset 0x08 however. What could be the problem?