firware xb24-zb zigbee end device digital io v-2721

I have a problem.

When I try to load the firmware to the XBee module seems to me the following:

Getting modem type…Programming modem…OK
Setting AT parameters…OK
Detected baud rate difference.
Make sure PC and modem baud rate is set correctly
Write Parameters…Complete

When trying to read it gives me error.

How to configure my module with firware xb24-zb zigbee end device digital io v-2721?


Do you mean you have a Digi XBee DIO Adapter? You certainly do NOT want to use this firmware on any other XBee as it assumes specific PCB support. If you only want to read/write I/O pins, then just use the normal AT or API firmware.

This firmware disables the serial port, so I am very surprised ‘getting modem type’ even works. You can only configure this firmware over the air (after it associates, which can be a problem if you have a dozen ZB coordinators within RF sight of your desk).

I have had better luck with the 2764 firmware, which is router or end-device. Then setting SM=0 causes it to be a router (and part of a mesh), and setting SM!=0 causes it to be a child, so not part of the ZB mesh.

I have a digi xbee dio adaper.

The finally configuration of my module was zigbee end divece API v2970

Can you explain me, how configurate firmware over the air?

What is the best program to handle xbee with automata.



This firmware is made to upload only over the AIR.
If you try with UART it will not work… . But you can configure your XBee with the following procedure in the other state…

Try it… It may help… With me it worked fine…

1.Connect the interface board to the computer via appropriate cable (USB or Serial) (If using Serial, connect power as well)

2.Make sure the XBee module is NOT plugged into the interface board

3.Open the X-CTU program and select the proper COM port.

4.The first screen you see in on the PC Settings tab. On this tab please change the baud rate to 38400 and put a check in the “No Baud Change” check box.

5.Navigate to the Modem Configuration tab

6.Select the proper modem type, function set and firmware version from the 3 drop down menus located about 1/3 of the way from the top of the window.

7.Click on the Show Defaults button and put a check in the “Always update firmware” check box.

8.Click on Write. (Yes, the module is NOT plugged in) An Action Required box will appear. This is good. When this happens, hold in the config/reset switch on the interface board and CAREFULLY plug in the module and then release the config/reset button.

9.You should now see that box disappear and a progress bar will appear along the bottom of the window. You will see the bar progress and then the box will appear again. This is good. Just hold in the reset switch on the interface board for about 1-2 seconds and then release. The box will disappear and the status at the bottom of the window will show that the write was complete.

10.Go back to the PC Settings tab and change the baud rate back to 9600 and uncheck the “No baud change” check box.

11.Click the “Test/Query” button. You should get a clean bill of health.


Ok, these are a perfect indications.

But in step 9 i´m can see that write was complete but step 11 is incorrect.Due to when copy AT paremetrers i´m get [error] in red colour.

Another question:
how configurate firmware for a adapter rs-485 because when i try my computer restarts

Am older version of XCTU might help, but the method documented above rarely works with the DIO/AIO.

“Over the Air” config means from a Digi gateway - the settings are shown under the web interface. If you have no gateway, you could issue AT comments remotely from another XBee, but that is not easy to explain.

This web page explains the more reliable way to reflash the AIO/DIA: