Function: 1061 - Not found in XCTU (XBEE 686)

I am working with a xbee 686 and am trying to use XCTU to do some testing. The radio module I connected to my pc discovered and added has “Function: 1061 - Not found in XCTU”. When I switch to configuration working mode I get the window of “search firmware?” has 'could not find a firmware for the selected device … ’ I tried with ‘Look for and install new firmware’ but I got this errors:
-Error while loading Firmware Library: “Remote host closed connection during handshake”.
-Error while performing force updates: Remote host closed connection during handshake

It’s my first time working with xbee, I tried to download a firmware from digi for the xbee 686 and I got 2 files “XB8X_A00A.ebin” and “XB8X_A00A.mxi”. I tried to install firmware from file and browsed to those 2 files but it looks they are not known as a firmware cuz I can’t find them to select.
Any Idea What mistake I made or What’s going on.

As far as I can tell, 1061 was a beta release. You would need to install the most current version of 1074 for the XB8-DP 10 K code.