Help with configuring XBee Pro 538 with XCTU v.

Hello, I am having an issue with getting XCTU v. to discover my XBee PRO 538 900 MHz devices. I am interfacing the device with the software via the Explorer Dongle. I have downloaded the appropriate drivers and firmware (I think), and the devices are straight out of the box (4 XBees, 2 USBs). Whenever I use XCTU to try to discover a device, I get the “Action required - reset your device” message. I click the reset button, and it brings up a sort of “dummy” radio in the list of radios in the software. Next to the function parameter is the statement “Not found in XCTU.” I tried to add the firmware to the library, but it still isn’t discovering it.

Your help is much appreciated. I am very new with all of this, so if I have left something important out of my question, or I have posted this in the wrong forum, please let me know.


XBee link:

Explorer Dongle link:

Do you know which firmware version is on the XBee?

Not sure if it’s loaded onto the XBee, but I think the most recent one I loaded into XCTU was XBee Pro DigiMesh 900 8062

Try version 8074 and 1074 from this page:

Sorry for the late reply, I have been busy with other things. I tried downloading both of those firmware versions, and when I try to update the firmware library, the “Installed radio firmware” window pops up and shows that nothing has been installed.

Try using the recovery tool to reinstall the firmware:

I’m an idiot. My question references an XBee PRO 538, I don’t think such a thing exists. I’m using the XBee-PRO XSC S3B (XBP9B-XCWT 002). I have the firmware for this device installed in the library, but the recovery tool won’t work because it continually searches for an active bootloader.

I’ve resolved the issue by using the “discover” tool to look for radios with other parameters besides the baud rate. Apparently this radio doesn’t use the default parameters. Thanks for the help