High Sleep current Xbee s2d and Grove SMT board

Using an Xbee S2D in a Grove SMT board. SM=1 When I take DIO8 to 3V3 the supply
current reduces to 800-1000uA. Have removed pot jumper, it reduced idle current
by about350uA but still the idle current is too high.

I ran into this same issue trying to get the Grove SMT board and the Xbee 3 ZigBee module (Firmware 100D XB3-24) into low power mode. I’m also seeing 800-1000uA with cyclic sleep. I was able to verify that it is indeed the SMT Grove board causing the high current sink. Removing the Xbee 3 module and powering the module directly I’m able to see the module drop down to ~4uA in cyclic sleep mode.

I’m seeing the UART_DIN and UART_DOUT pins sinking the majority of the current. Powering the Grove board via the battery input with 3.4V@500mA source and having to physically disconnect the spring contacts from these two pins to get the unit to drop down below 800-1000uA. I’ve tried via XCTU to disable these two pins, setting them to digital out, low and high, disabled with no luck. I would be curious if there is a configurable solution to correct this issue?

My current low power mode configuration is as follows:
a) Physically disconnect the DIN and DOUT pins from the spring contacts (lifting the pin out of the way).
b) Configure via XCTU:

  1. SM = 4 - cyclic sleep
  2. SP = 3E8 - 10 Sec sleep time
  3. ST = 1388 - 5 Sec Wake time
  4. D6 = 4 - Digital Out, Low
  5. P5 - P9 - Disabled
  6. D0 - Disabled
  7. D2, D5, D8, D9, P0 - Digital Out, Low
    8 ) PR - 0
  8. PD - 0
  9. All other settings set to defaults

Note: A key take away was to set pins to Digital Out, Low instead of Disabled otherwise the POT, and LEDS would still sink current. Hope that helps someone. Also note that when using the battery input the RT9167 LDO regulator consumes ~90uA, so that’s the lowest current consumption I’ve been able to achieve with the Grove board.