How to configure Xbee from an HCS12 (without a computer)?


I’m currently doing a project involving creating a network protocol based on the 802.15.4 (not using ZigBee). My antenna is a Xbee 802.15.4 (part No.: XB24-AWI-001) and I’m working on a HCS12 (MC9S12DP256) and the IDE CodeWarrior.

I was wandering how we could change the configuration of the Xbee (like the destination address, the AES Encryption Enable and other settings that we can see with X-CTU) without a computer, so without the help of X-CTU (changing the settings of the XBee with the HCS12)?

Research on the Internet told me that we would have to send “+++” first to get in the AT mode and afterward, send the commands (ie: “ATDL 01” and “ATWR”), but it is not working for a reason that I ignore.

Thank you very much for answering.

Sounds like you need to find out why you are not getting into command mode as that is how you would change these commands. By default, the command mode sequence is one second of silence, followed by +++ sent within one second, follow by one second of silence. If you are not doing this, then you are not going to enter command mode and you will not be able to modify any of the radios AT commands.

1 Like

Thanks for answering so fast.

I did as you mentioned with the silence moment and there is still nothing happening. Would you have other things to suggest?

Also, I was looking at maybe using the API mode instead (which would be faster). Is it good idea? If it is, any idea how to get it to the Xbee? From my understanding, when we are sending data on the serial port, we are above the MAC layer (which is the layer that the API mode uses).

Yes, from a processor, API mode is the preferred method of interacting with the XBee module.

As for your entering command mode issues. I would suggest connecting the radio to the PC and have XCTU restore it to defaults. Then try again. If you still can’t enter command mode, then either your Tx and Rx lines are crossed, you have a voltage issue or you are issuing something like a Carrage return when you should not be.

Thank you for the answers.

The AT mode still doesn’t work. So, I tried the API mode which is working.

For how to use the API mode here is a guide: