How to install edgeport/1 driver for windows vista?

I downloaded the file 40002537_D.exe that was supposed to work. When I try to install the software via device manager, vista gives me the message that it found the driver for Edgeport but failed due to:

“This operation requires an interactive window station”.

I also tried copying the files directly to system32 and system32/drivers but windows is still not recognizinfg the adapter.

The windows version is vista home 32bit english.
Thx,
Marcio

I’ll e-mail you a modified driver shortly that I’d like you to try. It should resolve that error. You’ll want to unzip the file that I’ll be attaching in my e-mail then point the found new hardware wizard to the location of that extracted file.

I am also experiencing this same problem with my Edgeport/1 and Windows Vista.

Using drivers: 40002537_F
Operating system: Win Vista Ultimate 32bit English

Error message:
"Windows found driver software for your device but encountered an error while attempting to install it.

This operation requires an interactive window station."

I would greatly appreciate any assistance with this.

Thanks in advance

David

Hi,

I´m jst ne in this forum and also searching for an Edgeport/1 driver for Vista as my edgeport does not seem to work in my laptop. Could you help me on this? I also got the 40002537 drivers and have installed it, but still the same result when I try to use it.

Please help me on this as I badly need to have this work on my laptop.

Thanks

Here’s a link to the latest Edgeport driver for Vista:
http://ftp1.digi.com/support/driver/40002537_F.exe

Does this help?

Hi,

I could not access the link that you gave me, any other way you could send me the file?

Thanks in advance.

Sure, I’ll e-mail it to the e-mail address in your profile as a .zip file attachment.

Thanks a lot.

I have installed the driver you sent me, it did had some improvements as now I think it recognizes the edgeport, but when I try to connect using SecureCRT software, nothing is being presented on the screen. Is there any other configuration I need to check in Vista and the Edgeport?

Thanks

Please take “screen shots” of the following:

  1. Windows Device Manager (maximized), with the “Ports (COM & LPT)” section expanded.

  2. Edgeport Configuration Utility (the “General” tab), with the Edgeport expanded so I can see the COM port number.

  3. Edgeport Configuration Utility (the “Version” tab).

David,

Try this driver instead, and let me know if the Edgeport installs.

Jeremy,

That driver worked brilliantly.

Thank you very much for your help.

David

Hi,

I have similar problem with Edgeport/4 and windows vista business. I donwloaded the driver package and managed to partially install it. Edgeport/4 is shown in device manager but configuration utility displays only 2 ports and they are not functional (port test fails and the ports are not shown in device manager). When the driver installed there was no individual port installation which I expected to see and windows still also displays “unknown device” in device manager.


** Keijo

Sounds like your Edgeport hardware may be defective. For troubleshooting purposes, can you see how it behaves on a different PC, running Windows XP? Use the current release v5.0 driver which you can download here:

http://ftp1.digi.com/support/driver/40002537_F.exe

Download the Edgeport driver: http://ftp1.digi.com/support/driver/40002537_J.exe. Once the Driver file has been downloaded, right-click 40002537_J.exe and select Run as Administrator. Click the Setup button. A black window will appear for the driver installation.06-Jun-2019,

I could not access the link that you gave me, any other way you could send me the file?

Edgeport support for Windows Vista was removed in the v5.70 Edgeport driver.

The previous release v5.30 Edgeport driver supported Vista and may be downloaded here:

https://ftp1.digi.com/support/driver/40002537_H.exe