How to solve (connecting to this Host PC) without rebooting


We have a problem, when our AnywhereUSB/14 device is rebooting 1 of our Windows 2008 R2 (on VMware) server is not reconnecting. It stays at “Connecting to this Host PC”. When we do a reboot of the Windows 2008 R2 server, everything starts working again.

We have tried to remove the AnywhereUSB/14 from the AnywhereUSB Remote Hub Configuration Utility and restarted the program many times. We have tried a different groep. Nothing seems to help.

It looks like it still trying to connect in the background maybe a session that hangs. We don’t want to reboot the server because there are other people connected to the server.

With kind regards,


We have the exact same problem. We are also using a Windows 2008 R2 VM in VMware. If we reboot our server it will connect and work properly for a couple days up to a couple weeks and then it stops working. We also see the exact same message “Connecting to this Host PC”. The only way I’ve gotten it to connect again without rebooting the server is to change the IP address on the Anywhere USB to another IP address and then the server will connect to it again. I’ve tried removing the original IP address from the Connection List Manager, but that still would not let it connect. My problem is that even though I can now see the USB hardware locks in Device Manager, my licensing software won’t see the dongles until I reboot the server. Bouncing the licensing software services doesn’t make the software search for the USB dongles. I am running the latest firmware and drivers for the Anywhere USB.

We are not using any kind of firewall on this server and the Anywhere USB is on the same local subnet. There is nothing weird or complicated with our configuration. The Digi Anywhere USB just isn’t reliable with our Windows 2008 R2 VM.

Hopefully Digi will see that this is a real problem and do something to fix it. I called support and the person I spoke to offered some ideas (none worked), but said if I actually want them to troubleshoot my issue I’d have to pay them. It’s rediculous to have to pay for support when the issue has got to be with the product and not how it is configured.

Have you tried to uninstall the AnywhereUSB drivers and reboot the vm then reinstall the latest AnywhereUSB drivers?

Verify that the USB devices connected have the latest driver installed?

Ensure you do not have a duplicate ip address issue?
Start a constant ping on that ip address and unplug the power, the ping test should stop responding.

Verify there are no firewall issues and antivirus applications can do intrusion detection that can block the AnywhereUSB drivers.

Ensure you have full admin rights when installing the AnywhereUSB drivers.

I am having the same problem that PBurton below describes. Did anyone come up with a real solution?

I have the same problem on Win2012 on WM.
I will check Ip conflict though.
Conflict or not, how can I restart the driver(s).
The USB system devices are gone.

Hellow from 2019. We have latest firwares and drivers and the same issues when connecting USB devices to host PCs (not virtual PCs). Three AnywhereUSB/4 and five users on Windows 10 x64 1703 and 1809.
We romved antivirus, checked ip conflicts, checked administrator rights, disabled firewall, looked for several hours at continuos ping without loss… And no luck.

We have the same problem on a Windows Server 2016 virtual machine. It just hangs on “Connecting to this Host PC”

We have 82002116_R1 firmware / v1.97.2201 from Jan 15, 2019. The only way to solve this is a reboot. And that isn’t good.


This is happening across 6 of our Win 2016 Servers.
Reinstallation of the AnywhereUSB SW does not solve this.

Win 2016 automatically downloads the USB drivers so no need to check this.

There is no firewall or IP address issue and all VMs are logged on as Admin.